• Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


charlieb

Starting Problems

2 posts in this topic

I have recently started having problems with my 2000 w reg fiesta starting. I have replaced the battery and had the alternator checked (which is working fine), but in the cold the car doesn't like starting. It will start straight away though when connected to another for a jump start. Any help or ideas please!!!!

Share this post


Link to post
Share on other sites
 

Sounds more like its an issue with the fuel and/or air filter being clogged up as opposed to an electrical fault...

Does the car try to start? does it try to turn over, or does it not even get that far?

If you put the headlights on, do they flicker wildly as you try to start, or just the usual dimming for a moment...?

Moving this to the Fiesta section for more visibility...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now