• Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


ben goddard

Bonnet Wont Close

13 posts in this topic

i opened my bonnet to refill screen wash and now it wont close.

It catches on the safety catch, but not the spring catch.

so far i have tried removing the rubber studs to see if they were causing a problem, nope.

wd40 on the catches, nope.

so it now closes on the safety catch (with the yellow release) but not on the spring one.

as far as i know the cable under the bonnet looks ok (i think), i have included a picture, but i took the picture facing forwards, so its back to front.post-23770-0-33478200-1359975837_thumb.j

Share this post


Link to post
Share on other sites
 

Hi Ben

I don't know if this will help, but I had the same problem with my Galaxy Mk3

Everything seemed to work ok (spring loaded locking mechanism - tested with a screwdriver :mellow:, released ok with the bonnet latch) but the bonnet just couldn't push the first part of the mechanism out of the way to get to the locking mechanism

So, being careful not to trap my fingers I just moved the yellow catch slightly while closing the bonnet and voila, bonnet closed ok

Hope this helps

Ian

Share this post


Link to post
Share on other sites

Hi Ben

I don't know if this will help, but I had the same problem with my Galaxy Mk3

Everything seemed to work ok (spring loaded locking mechanism - tested with a screwdriver :mellow:, released ok with the bonnet latch) but the bonnet just couldn't push the first part of the mechanism out of the way to get to the locking mechanism

So, being careful not to trap my fingers I just moved the yellow catch slightly while closing the bonnet and voila, bonnet closed ok

Hope this helps

Ian

thanks for the reply, tried it but no fix. it does go into the yellow catch easily, but not the spring one. it seems as if the spring catch, doesnt move :/

Share this post


Link to post
Share on other sites

Could it be that the locking mechanism is in the locked position and just needs releasing with the bonnet latch in the car?

Share this post


Link to post
Share on other sites

Could it be that the locking mechanism is in the locked position and just needs releasing with the bonnet latch in the car?

i tried that. nothing happens, but (im no mechanic) that cable for releasing the bonnet, (that silver wire in the pic) seems like it should be attached to something?

Share this post


Link to post
Share on other sites

i tried that. nothing happens, but (im no mechanic) that cable for releasing the bonnet, (that silver wire in the pic) seems like it should be attached to something?

From the picture it looks like the cable (wire) has popped off the lever, have a go at re-attaching it/ get someone who can fix it, its probably a good idea to get it sorted because if you run the car with the bonnet not closing right air can get under it at speed and damage the bonnet/ windscreen/ roof

Share this post


Link to post
Share on other sites

From the picture it looks like the cable (wire) has popped off the lever, have a go at re-attaching it/ get someone who can fix it, its probably a good idea to get it sorted because if you run the car with the bonnet not closing right air can get under it at speed and damage the bonnet/ windscreen/ roof

yeah i didnt think the cable looks right, its not attached to anything, and i cant see where it attaches, do you know what/where it attaches to?

Share this post


Link to post
Share on other sites

Hi, did u manage to figure out what was wrong as im having the same problem!

That wire is not attached to anything but rather is used to pull back the locking mechanism to release the catch. Unfortunately the locking mechanism is not moving forward on its own to engage once it has been released. Not sure if its just a wd40 job although I have sprayed on a little to no avail. Have managed to get the bonnet closed by simply pushing the locking mechanism forward towards the catch before closing the bonnet as normal.

Any help would be much appreciated!

Share this post


Link to post
Share on other sites

I had the same problem a while back and tried wd40 but it didn't work. So I got a small wire brush cleaned it all an the got some spray grease. That worked a treat.

Once you've pulled the catch the cable don't do much it goes all slack until you close the bonnet back down.

Hope you get it sorted

Adrian.

Share this post


Link to post
Share on other sites

Wasn't this on the Ford free fix list? Mine did the same but during the service they greased it with something yellowish. Never had a problem since. Guess they had problems closing it after they'd finished! haha

Share this post


Link to post
Share on other sites

Has anyone come up with a solution to this problem? My 2010 Fiesta has had an intermittent fault since I bought it new. I thought the garage had fixed it but I can't close the bonnet today after topping up with screenwash.

Any ideas?

Share this post


Link to post
Share on other sites

I had the same problem, ended up getting the AA out as I didn't fancy driving it home and couldn't lock it! He said it was a faulty bonnet catch but slammed it shut with brute force! I took it in to Ford and they refused to replace it even though the AA mechanic said it needed replacing!(It was under warranty at this point). All Ford did was to grease it up big style! Seems to have done the trick!

My suggestion is to either call your breakdown if you have it or grease the hell out of it!

Share this post


Link to post
Share on other sites

Got this problem as well. Very annoying the bonnet catch dosnt seem to spring when fully depressed.

I got a screwdriver on hook for the bonnet and can push the second latch down but the release latch that holds this closed isn't clicking into place. have tried WD40 but think im looking at new bonnet latch any idea how easy to fit?

found one on fordparts for £30.

****FIXED***

Fixed this with lots of wd40 and 30minutes working the lock backwards and forwards releasing catch and closing again seems to of worked.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now