Jump to content


Hello. Problem with my lights...help please !

  • Please log in to reply
1 reply to this topic

#1 nickywoo



  • New Member
  • Pip
  • 2 posts
  • Ford Model: ka
  • Location:

Posted 11 March 2009 - 12:26 PM

Hiya..Just wondering if anyone can help ...

My rear lights and dashboard lights have stopped working. The front lights are fine as are the indicators and brake lights...(but not if i put the handbrake on).

Read on another forum that it has something to do with the side light switch..so i tapped it..(yes im a woman) and for a moment the whole lot came back on...but next time i tried it was the same as before...

I've checked all the fuses and bulbs..so i now havent a clue whats going on...

Really frustrated at the moment with my ka...It's not new but not exactly ancient...51 plate..and everything seems to failing this past month..MOT is due this month and power steering rack is on the way out.. leaking fluid all over the show (350 quid apparently..) and now the lights... Spent 250 on it last month for other repairs and if it carrys on at this rate i'd be able to buy myself a new one in 6 months...

Can anyone give me a clue as to what might be wrong with it... Gonna take it to a garage as soon as payday comes round but sick of spending money on the damn thing !

Thanks... :-)

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,565 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 11 March 2009 - 04:00 PM

its a well known fault on the ka that the sidelight switch plays up, tapping the switch and the lights coming on is a sign that a new switch is needed.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users