Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


RonaldFord

No Ecu Communication

1 post in this topic

Hi. I bought a 1999 Mondeo MK2. 2.0L Zetech engine. Unbeknown to me, this vehicle could not be repaired by the Ford Dealers. Dash lights up when you turn the key, but the engine does not crank. Starter is ok. The Dealers replaced the ECU and interior fuse box. They swopped these items from an identical vehicle without any luck. The "faulty" ECU and fusebox worked fine in the other vehicle. The only items they did not swop was the engine compartment fuse box and the wiring looms. They checked the engine and dash wiring looms and found no problems there. They could not communicate with the ECU. Please advise what could be the problem. I checked the connectors and engine fuse box. They all seem ok. Thanks.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now