Jump to content


Show
Photo

Mondeo Clicking Brake Pedal


  • Please log in to reply
5 replies to this topic

#1 SOSGC

SOSGC

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo 2.0 tdci
  • Location: Cumbria

Posted 11 February 2013 - 09:14 PM

Can anyone offer me some assistance please?
My 2010 60 reg 2.0 tdci has an annoying intermittent click as I release the brake pedal.
Other forums/sites imply this is a known issue that Ford refuse to fix as it is not a safety issue!
Before I start the ball rolling with my local dealer can anyone offer any advice or a possible fix?
Thanks in anticipation
Gary

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 SOSGC

SOSGC

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo 2.0 tdci
  • Location: Cumbria

Posted 13 February 2013 - 04:58 PM

Sorted.........for now.
Brake switch plunger lubricated with light-weight grease. Probable cause? The heater being used a lot more recently and drying out the switch plunger (well it is February) and it intermittently sticking on the final travel as I removed my foot from the pedal.
Hope this is useful to others
I will advise if any changes occur.
Gary


#3 stef123

stef123

    Ford Enthusiast

  • Management
  • 4,968 posts
  • Name: Stef
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 13 February 2013 - 05:07 PM

Sorted.........for now.
Brake switch plunger lubricated with light-weight grease. Probable cause? The heater being used a lot more recently and drying out the switch plunger (well it is February) and it intermittently sticking on the final travel as I removed my foot from the pedal.
Hope this is useful to others
I will advise if any changes occur.
Gary


Sorry no one replied to you, posts do get missed sometimes.

I hope you have found the problem and a cure, certainly sounds like it.

#4 SOSGC

SOSGC

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo 2.0 tdci
  • Location: Cumbria

Posted 13 February 2013 - 05:12 PM

Thanks

#5 SOSGC

SOSGC

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo 2.0 tdci
  • Location: Cumbria

Posted 14 February 2013 - 05:16 PM

Unfortunately it's back again 24 hours later.


#6 stef123

stef123

    Ford Enthusiast

  • Management
  • 4,968 posts
  • Name: Stef
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 14 February 2013 - 05:39 PM

sounds like it might be a new brake pedal switch then?

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users