Jump to content


Show
Photo

Escort Si 1997 Starting Problems ???


  • Please log in to reply
1 reply to this topic

#1 cavvy

cavvy

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: craig
  • Ford Model: Escort si estate
  • Year: 1997
  • Location: West Midlands

Posted 15 February 2013 - 11:58 AM

Hi im new to the site.
I have just brought my first ford a 1997 escort si estate on the first day of owning the car all was fine for the first few hours then i switched the car off left it ten minutes and it wouldnt start again.
Car wouldnt start what ever i tried I left it over night and it started straight away ,Yesterday i cleaned it with it ticking over same thing happend swithched the car off when finished tryed to restart for 3 hours and nothing checked cut off switch relay and fuse all fine left the car over night and it started ???? When it wont start i have a sprk but the fuel pump is not kicking in

Any help would be appreciated

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 cavvy

cavvy

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: craig
  • Ford Model: Escort si estate
  • Year: 1997
  • Location: West Midlands

Posted 15 February 2013 - 12:16 PM

Also how do i get to the fuel pump? its a 1997 escort estate


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users