• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


riadach

Car Won't Start.

Recommended Posts

I've a ford puma, 00 reg. The car won't start and there's no power to the plugs. A new coil and ignition sensor has just been fitted, yet there's still no power.

Does anyone know what could be wrong?

Share this post


Link to post
Share on other sites
 


Does the immobiliser stop the pump from working because the fuel pump still works?

its probably not the immobiliser then as it would stop fuel and spark.

Share this post


Link to post
Share on other sites

Hi i had the same problem with my fiesta.Engine would turn over fast but not start, no fault codes, no spark.Could not believe it was the battery.If the batt is not giving off 12 volts the ignition wont work ,even though it turns engine over fast.Have your batt checked.Thought i would put this on even though its been over a year since the trouble.I was pullin my hair out tryin to find the problem,was fooled by engine turning fast.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now