Jump to content


Photo

Help!!!!


  • Please log in to reply
2 replies to this topic

#1 Kadan II

Kadan II

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Name: Michael
  • Ford Model: focus
  • Year: 2003
  • Location: Aberdeenshire

Posted 15 February 2013 - 11:26 PM

I recently bought a 03 Focus 1.8 TDCi 115 it has started giving probs. The glow plug light on dash flashes then it starts to slow down and then concks out but starts no problem and runs for about 50 miles and dose the same again. I don't know when it last had a service but had a look at the air filter and it hasent been change for long enough so I expect the fuel filter will be the same could this be the solution to my problem needs a good service?????

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 DanGersFord

DanGersFord

    Dan The Gas Man

  • New Member
  • PipPipPipPipPip
  • 3,498 posts
  • Name: Daniel
  • Ford Model: Fiesta ST3
  • Year: 2014
  • Location: Scotland
Contributor

Posted 15 February 2013 - 11:51 PM

That was my first thought yeah id take it and get a full service done.

#3 Kadan II

Kadan II

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Name: Michael
  • Ford Model: focus
  • Year: 2003
  • Location: Aberdeenshire

Posted 16 February 2013 - 01:11 AM

[background='']Many thanks for reply i'll get filters today n do the job [/background]


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users