Jump to content


Show
Photo

Mk3 1.8 Zetec Engine In Need Of Tlc


  • Please log in to reply
5 replies to this topic

#1 Eddie777

Eddie777

    Member

  • New Member
  • PipPip
  • 10 posts
  • Name: Ian
  • Ford Model: Mondeo Zetec 1.8
  • Year: 2001
  • Location: Staffordshire

Posted 24 February 2013 - 11:58 PM

Hi.
my 132000mile mk3 1.8 Zetec petrol is in need of help.
Its burning a fair bit of oil, and last week the engine management light came on with 3 codes.
PO173
PO325
PO400
I took it to a local garage, who told me the loss of oil was partly due to Cam Cover gasket leaking, but didnt change it, as he said engine is worn out, and probably needs a replacement transplanted.

I asked him if he did a compression test, and he said no.

I`ve been doing some digging, and found that if car has been running with thermostat stuck open, for a considerable amount of time, which it had from previous owner, that its possible the crankcase breathers are blocked.
Am I clutching at straws?

Cheers
Ian Edwards

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 317 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 26 February 2013 - 05:50 PM

think P0400 is egr valve code.i would do a compression check.depending what the oil is like if its black or not i mean mine on 208,000 miles and still going,but read the piston rings on the 1.8 was of a cheap brand.dose it smoke on startup or if you in gear n go down a hill in gear with foot off throttle then at bottom of hill hit the throttle dose it puff blue smoke??i treated mine to a wyns engine flush last oil change

#3 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 317 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 26 February 2013 - 05:57 PM

http://autodiagnos.c...rd/ford_dtc.pdf

Try this for codes

#4 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 317 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 26 February 2013 - 05:59 PM

or pcv blocked thats poss

#5 Eddie777

Eddie777

    Member

  • New Member
  • PipPip
  • 10 posts
  • Name: Ian
  • Ford Model: Mondeo Zetec 1.8
  • Year: 2001
  • Location: Staffordshire

Posted 26 February 2013 - 08:12 PM

think P0400 is egr valve code.i would do a compression check.depending what the oil is like if its black or not i mean mine on 208,000 miles and still going,but read the piston rings on the 1.8 was of a cheap brand.dose it smoke on startup or if you in gear n go down a hill in gear with foot off throttle then at bottom of hill hit the throttle dose it puff blue smoke??i treated mine to a wyns engine flush last oil change

I will try the down hill suggestion. Not seen that before.
Are you talking of engine braking, and then floor it?

#6 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 317 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 27 February 2013 - 06:39 PM

yea if you go down hill in like 4 or 5th foot off throttle then when get to bottom put foot on throttle if you look in mirror you might see smoke

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users