• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Rossitron

53 Mondeo 2.0 Tdci Cold Start Problem

4 posts in this topic

Hi everyone

I've had the car since September and it has the glow plug problem, if you over gear or try and progress too much in 5th / 6th the flashing glow plug light comes on and it goes into limp mode. I have had a few bottles of Wynn's in the tank and this has improved some, but if you rev too hard, it still black smokes a little.

Since Christmas I've had trouble starting it in the mornings with the cold weather. At first I could jump start it from another car, but this stopped working and it had to be bumped off. As soon as it is going, it is fine for the rest of the day, until it is left overnight!

It is a bit rough when idling, but I changed the fuel filter on Monday and this seems to have improved. On Tuesday morning I was able to start it (with a bit of effort), but again today it was back to being bumped off.

I had the battery tested and the guy stuck a code reader on, which threw up the P0251 fault, someone else suggested it could be the injectors. I haven't tried any easy start, which I will try tomorrow. I was wondering if anyone had any other suggestions before replacing the injection pump fuel metering control?

Any help would be appreciated.

Share this post


Link to post
Share on other sites
 

the most common cause of P0251 is a knackered injector, first job would be to get a leak off test done this will confirm if the car has a bad injector or not.

Share this post


Link to post
Share on other sites

the most common cause of P0251 is a knackered injector, first job would be to get a leak off test done this will confirm if the car has a bad injector or not.

Thanks for the reply, would a knackered injector(s) cause cold starting problems too?

I used easy start yesterday morning and it started on its own this morning! I'm still getting the intermittent glow plug problem, but the last time it happened, it didn't go into limp home mode, the plug just flashed.

I will do a leak off test as soon as I can get the gear.

Share this post


Link to post
Share on other sites

Update: Leak off test complete, looks like injectors 1,3 and 4 are knackered.

How much does it cost to have them reconditioned and is it only Ford that can do it?

post-41300-0-49360700-1362506959_thumb.j

post-41300-0-65261700-1362506971_thumb.j

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now