AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


neps

New Here, Need Some Input On Retrofittings

167 posts in this topic

I paid €74 for it at my dealer. They are hard to find because every car with front damage has also damaged the sensor

Share this post


Link to post
Share on other sites
 

Got the new harness today, partnumber: 1580659

This is the correct one for 2009 models with 2 connectors for the radiounit.

The harness goes in between one of the old connectors to the radiounit and the BT module. It also provides two new connectors that goes to the headunit.

1 BT module

2 USB and AUX inputs

3 radioconnector input, use the current connector to radio.

4 Two new connectors that goes to the headunit. The grey/white one replaces the current grey/white one.

5 microphone

attachicon.gif1580659.jpg

I installed this harness today, this has now broken my AUX input.

I noticed that the wire from aux-in now goes to two pins on the BTmodule connector, and in the aux connector on the headunit also goes to two other pins on the BT unit. I think this means that the BT/USB does use the same wires to the headunit to both BT/USB and AUX. However now none og the above works. I guess its just because I need to get it coded.

If I'm understanding this correctly, then can I use this harness to bridge between my 2009 stereo and the 2010+ loom I have?

I would also need the 2009 AM module USB cable though.

Share this post


Link to post
Share on other sites

What loom do you want to bridge? The one i got yesterday will not fit a 2010 radio. It will not fit to a 2010 cars loom. But it will fit any year btmodule. The 2009 harness does not come with the mini-USB cable, it has the large Ford style usb

2010 = 1 big connector for radio

2009 = 2 connectors for radio.

Share this post


Link to post
Share on other sites

What loom do you want to bridge? The one i got yesterday will not fit a 2010 radio. It will not fit to a 2010 cars loom. But it will fit any year btmodule. The 2009 harness does not come with the mini-USB cable, it has the large Ford style usb

2010 = 1 big connector for radio

2009 = 2 connectors for radio.

I have a 2010 loom that has the grey connector but won't fit my 2009 stereo, I need the large style USB connector for my 2009 non mini-USB BT module.

So it appears this harness will solve both my issues by bridging between my loom and my stereo and having the USB connector I need rather than the MIni-USB one :D

Share this post


Link to post
Share on other sites

Yep, this harness will be the right one for you. Partnumber: 1580659.

The price I payed was 115£

Share this post


Link to post
Share on other sites

Yep, this harness will be the right one for you. Partnumber: 1580659.

The price I payed was 115£

Did you get it through a dealer or 3rd party parts supplier?

Share this post


Link to post
Share on other sites

I bought it from the official Ford dealer.

Share this post


Link to post
Share on other sites

Got the car recoded today, and it all works!

So it doesnt matter wich BT module you got, they all work as long as the harness is for the right build year.

The trip computer does not work. But after the recoding and new asbuilt file, at least the trip button on the stalk is working, it now resets the trip counter. But it would be great to have the other functions working aswell.

NicklasCc likes this

Share this post


Link to post
Share on other sites

It did that for me before the recoding. Which IDS version did you use?

Share this post


Link to post
Share on other sites

I dont know. The dealer did it. Does the IDS version matter?

Dealer thought it could be because im missing the temp sensor(??)

Maybe I didnt try holding the trip stalk before I got it coded.

Anyway, I printed a small note with my instructions to the dealer when I left the car there. Telling them wich asbuilt file to use, and where to find it on my USB stick. I also wrote that I didnt have the microphone nor the temp sensor, and that they should ignore any fault codes or such related.

When i picked up the car they told me that they had spent half the day to troubleshoot the microphone. I asked if they had not read my note. I got no answer as the mech that did the job was not available.

So, are we sure that the trip functions should work regardless of the tempsensor? Should I take it back next week and demand that they upload my new asbuilt file again?

Share this post


Link to post
Share on other sites

Got the car recoded today, and it all works!

So it doesnt matter wich BT module you got, they all work as long as the harness is for the right build year.

The trip computer does not work. But after the recoding and new asbuilt file, at least the trip button on the stalk is working, it now resets the trip counter. But it would be great to have the other functions working aswell.

Congratulations on the result, neps!

I am doing the same upgrade (no bt --> bt + usb) here in Denmark, and only need the Bluetooth loom (1580659)

According to the online catalogue you mentioned earlier this loom is for a Right hand driven car whereas the 1580658 is for a Left hand driven car... Since you have ordered the 1580659 i assume that it possibly is the same loom..?

Does the VOICE button on the new indicator stalk you installed work aswell after coding, and was the trip computer working before the coding (km/l, km to refuel, avg. speed) ?

Share this post


Link to post
Share on other sites

The trip computer should work without the temp sensor.

Share this post


Link to post
Share on other sites

Congratulations on the result, neps!

I am doing the same upgrade (no bt --> bt + usb) here in Denmark, and only need the Bluetooth loom (1580659)

According to the online catalogue you mentioned earlier this loom is for a Right hand driven car whereas the 1580658 is for a Left hand driven car... Since you have ordered the 1580659 i assume that it possibly is the same loom..?

Im am pretty sure I ordered the left hand part, but when i check now I see that i ordered the right hand.

The rhd is pretty long, so I had to tuck it away above the footwell. Maybe the LHD part is cheaper. ( i payed £120-ish (1250 kroner)

Does the VOICE button on the new indicator stalk you installed work aswell after coding, and was the trip computer working before the coding (km/l, km to refuel, avg. speed) ?

The voice did not work at all before coding. After coding it asks me to speak a command. The trip did not work before, and does not work now after (as i wrote in the previous post) All it does is resetting the trip counter.

Share this post


Link to post
Share on other sites

Okay, i'll just order the RHD loom, then i have some length to work with. It's around the same price here aswell.

Awesome! :lol: All i need is the loom now and the coding from my dealer. What did they charge you for that? around 800 kroner?

I think it's because your car is a Ambiente/Trend model that the trip computer isn't there..?

Share this post


Link to post
Share on other sites

They charged 1260 kroner for a five minute job. I checked the price at a other dealer first, they quoted 900, but they was not so cooperative, and since I know the guy at the last place i chose them. I got a coupple of other things sorted at the same time.

My car is a econetic, model with low fuelconsumption.green shiftlight etc.

Theres no trip computer there, but that shoul have been enabled now with the new asbuilt file I got from iNath. Just need to confirm this first before I claim them wrong and demand the work done again.

Share this post


Link to post
Share on other sites

Okay, i'll just order the RHD loom, then i have some length to work with. It's around the same price here aswell.

Did you check the price for both rhd and lhd looms? Im wondering If the rhd is more expensive because its not our market.

I first bought the 1720952 loom for 2011 models, that costed half the price.

Share this post


Link to post
Share on other sites

I thought so, they are pretty expensive with stuff like this.

Aah okay, i thought that it was standard on that model, since you have the little "game" with getting long a mileage.. I guess i was wrong :)

I actually haven't checked it, i first chekced the number on the database afterwards. The actual price here in Denmark for (1580659) is 840kr + 25% moms, so it comes up to 1050 kroner. I will check it when i am going back to my dealer, if the LHD loom is cheaper, i'll order that instead. :)

I got the 2010-2012 loom from a breakers yard this october which i can't use... So if anyone is interested!! ;)

Share this post


Link to post
Share on other sites

Yes Niklas I am interested. Do you have pics of the connectors?

Share this post


Link to post
Share on other sites

I want to make sure it will fit, obviously. If it fits I'm happy to buy it from you for the price you paid and shipping costs ( if they are not extremely high from DK to NL).

Share this post


Link to post
Share on other sites

i also have that 2010 loom for sale, told you earlier :)

I took Pics of that loom and they are posted previous in this topic. It have that extra 10 pin connector that fits nowhere.

Share this post


Link to post
Share on other sites

Maybe Nicklas's is different and it will fit my big connector

Share this post


Link to post
Share on other sites

Ok, worth a try, but i doubt it will be different :)

Share this post


Link to post
Share on other sites

The loom i have has the same connection as neps' but i also have the BIG loom that connects the whole front, from a 2010 model which the Bluetooth loom goes into.,

Its a bit more dificult to change, but it IS possible with a free weekend :) it took me about 8-10 hours to change it, i dont know what you do for a living, but if you're a mechanic you can probaly do it much faster!

All you really need is just to track where each of the connectors go to and remember to plug them ALL in (i forgot to connect the light switch which resulted a no starting car)..

But as long as you keep track and plug all the connectors in.......... Its easy peasy.... ;)

I took mine out again because it didnt fit my computer in the car, so now its just in storage and for sale :)

Share this post


Link to post
Share on other sites

Thanks for the offer but it sounds like a lot of extra work. I'd rather just buy the right BT loom for the 2011 Fiesta. If I find a fitting one I'm happy and otherwise I will wait for one to get scrapped. Hopefully they will let me take out the parts myself. Time is on my side, I currently have alternatives for USB and Bluetooth ( Griffin Autopilot and a Parrot thing I can remove)

Share this post


Link to post
Share on other sites

This is the right model loom that i have for the 2010-2011-2012 models

The only problem is that the bt-loom has to go into the Big loom and not just the radio loom which the pre 2010 models do.....

But yes, if you can make an adaptor of some kind... I dont think you can buy one from Ford.. :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now