• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save


Peng12

Door Open Light

9 posts in this topic

I have one more niggling problem i would like you guys to help me with please :)

When ever i turn my lights on the red door open light comes on with it and goes out when i turn the lights off. It works as normal when doors are open as long as the lights are off. Its really bugging me now lol

Share this post


Link to post
Share on other sites
 

only place i can think of where the two circuits meet, is the multi function control module, might have a bad connection, or possibly water sneaking in and getting on/in module.

either that or earth connections....i know earths for interior lamps are behind the kick panels or base of the inner sill panels.

Share this post


Link to post
Share on other sites

Is that the one that controls the central locking etc under the dash?

Share this post


Link to post
Share on other sites

does what it says on the tin :)

central locking certainly runs through it, so probably yes...cant remember if it has a seperate module as well...from memory, multi mod sits behind drivers kick panel or maybe slightly higher

Share this post


Link to post
Share on other sites

Brilliant mate thanks. I'll have a look at it tomorrow :)

Share this post


Link to post
Share on other sites

have a copy of autodata which gives fairly decent wiring diagrams on fords, if you let me know exact model/year ect, can sort out which wire of module goes where....would take time though as there is plenty of them :)

Share this post


Link to post
Share on other sites

Thanks mate. Its a early mk3 (2001) 1.8 mondeo zetec

Share this post


Link to post
Share on other sites

no worries, just had quick look, far as i can tell, circuits meet at multi mod [which is near datalink connector not kickpanel as i thought, so less likely to be a water ingress problem] but also meet at instrument control module, which is mounted on back of instrument panel.

if it was me, i would check interior/exterior lights common earths first, which are...

2 earths connections behind drivers kick panel, one of which is slightly higher up than kick panel itself. [only two connections in that area)

one earth located at foot of passenger side inner sill, roughly inline with door hinges.

finally, one i would go for first, in the boot on passenger side somewhere close to rear lamp assy.

need to check all wires/terminals at those points...if all thats ok, starts to get a bit more complicated...have a go at them first, let me know if problem still there.

Share this post


Link to post
Share on other sites

Thanks for that mate. Ill let you know what I find

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now