Jump to content


Show
Photo
- - - - -

Help.. Fez Undriveable Thanks To Transmission Light :(


  • Please log in to reply
9 replies to this topic

#1 Jack7

Jack7

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 142 posts
  • Name: Jack
  • Ford Model: Fiesta TDCi Zetec S
  • Year: 2009
  • Location: Renfrewshire

Posted 04 March 2013 - 07:03 PM

Hey guys, long time since ive been on.. mainly because my car has had zero modifications since I last posted.

 

From when I got the car in dec 2011 the transmission light would come on intermittently once every so often but it never caused any problems and no garage could pick up what the problem was.

 

Now the light comes on and when its on the car loses all power, and the accelerator goes dead to responses if its revved and the car revs itself up to about 1.5k. rpm. :(

 

Now the strange thing is its not showing any error codes, its been at 2 garages and a specialist diagnostic guy has been out, and the light has stayed on in the past for a few hours to two weeks.

 

Also, Ive had the accelerator replaced as that was the only thing the garage I took it to could think it was. 3 hours later it broke down again. Its now worked absolutely fine and as normal for a week but has came on again and again its undriveable.

 

Anyone any ideas why or what this is?

Any advice would be appreciated as im at my wits end trying to figure out what it is!

 

Ive attempted to upload 2 videos to show the noise it makes when the engine is on which seems mostly normal and then the noise that comes from the engine bay immediately after turning the engine off. :/

 

Apoligies for the mega long post haha! :)

Attached Files

  • Attached File  fezz.MOV   3.44MB   60 downloads
  • Attached File  Fez.MOV   842.79KB   42 downloads


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 DieselPig

DieselPig

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 265 posts
  • Ford Model: Fiesta Zetec 1.6 TDCi
  • Year: 2011
  • Location: Gloucestershire

Posted 04 March 2013 - 09:53 PM

I will hazard a guess and say that is the EGR valve or actuator making that noise. If the EGR valve sticks open this will cause the EML light to come on and the car will go into limp home mode, hence the poor throttle response.



#3 Jack7

Jack7

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 142 posts
  • Name: Jack
  • Ford Model: Fiesta TDCi Zetec S
  • Year: 2009
  • Location: Renfrewshire

Posted 04 March 2013 - 10:36 PM

I will hazard a guess and say that is the EGR valve or actuator making that noise. If the EGR valve sticks open this will cause the EML light to come on and the car will go into limp home mode, hence the poor throttle response.


Thanks for the reply, is the eml light the same thing as the transmission light?
Also any ideas how much it costs to replace an egr valve? :/

#4 DieselPig

DieselPig

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 265 posts
  • Ford Model: Fiesta Zetec 1.6 TDCi
  • Year: 2011
  • Location: Gloucestershire

Posted 05 March 2013 - 12:36 AM

EGR assembly is a big lump, not sure what parts are replaceable. I would have it removed and checked for operation first, may just need a clean.



#5 Jack7

Jack7

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 142 posts
  • Name: Jack
  • Ford Model: Fiesta TDCi Zetec S
  • Year: 2009
  • Location: Renfrewshire

Posted 05 March 2013 - 12:56 AM

EGR assembly is a big lump, not sure what parts are replaceable. I would have it removed and checked for operation first, may just need a clean.


Ah. Im beginning to think I might just be better selling the car, it sounds like even just getting that cleaned could be an expensive job :/
Would a faulty egr valve work sometimes & not work other times? Just wondering as the car seems to be going through phases of being fine then becomes undriveable :(

#6 DieselPig

DieselPig

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 265 posts
  • Ford Model: Fiesta Zetec 1.6 TDCi
  • Year: 2011
  • Location: Gloucestershire

Posted 05 March 2013 - 08:58 AM

Getting it cleaned could be expensive if you take it to a garage, my Mondeo suffered the same problem and I cleaned mine myself, took me all day!

 

Yes it can be intermittent, you could try a fuel additive such as BG244 and take the car for a high speed run and see if that cleans it out.

 

http://www.powerenha...el-fuel-cleaner



#7 Jack7

Jack7

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 142 posts
  • Name: Jack
  • Ford Model: Fiesta TDCi Zetec S
  • Year: 2009
  • Location: Renfrewshire

Posted 05 March 2013 - 07:05 PM

Getting it cleaned could be expensive if you take it to a garage, my Mondeo suffered the same problem and I cleaned mine myself, took me all day!

 

Yes it can be intermittent, you could try a fuel additive such as BG244 and take the car for a high speed run and see if that cleans it out.

 

http://www.powerenha...el-fuel-cleaner

thanks a lot for the link, so when it starts working again try fill it right up and put this in it? 



#8 DieselPig

DieselPig

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 265 posts
  • Ford Model: Fiesta Zetec 1.6 TDCi
  • Year: 2011
  • Location: Gloucestershire

Posted 05 March 2013 - 07:26 PM

Run the fuel low and when you fill up empty the whole tin in first then fill up with diesel, get on the motorway and put your foot down!



#9 Jack7

Jack7

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 142 posts
  • Name: Jack
  • Ford Model: Fiesta TDCi Zetec S
  • Year: 2009
  • Location: Renfrewshire

Posted 05 March 2013 - 07:28 PM

Run the fuel low and when you fill up empty the whole tin in first then fill up with diesel, get on the motorway and put your foot down!

 

Ah ok doke, would something like redex work just as well? Only I dunno when my car will start working and I could buy a bottle of redex at a petrol station haha :P



#10 DieselPig

DieselPig

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 265 posts
  • Ford Model: Fiesta Zetec 1.6 TDCi
  • Year: 2011
  • Location: Gloucestershire

Posted 05 March 2013 - 08:25 PM

BG244 is much better than Redex.



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users