Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Fiesta Silver1.4

Mondeo Zetec S 2.0 Automatic

5 posts in this topic

Hi guys,

Posting on behalf of my old man. He's got the Mondeo Zetec S 2.0 automatic. Owned for a few years now and has always run smooth and started first time, never had any problems.

However, over the past few months, (sometimes) when setting off it judders ever-so slightly, but then is fine. However, when up at speed around 55+ (if you take your foot off, or sometimes press for slight acceleration it sometimes judders as if it was about to stall, however doesn't and continues to go.

Any Ideas my friends?

I'm at a loss personally!

Cheers,

Rob :blink:

Share this post


Link to post
Share on other sites
 

Look into the auto trans fluid level it maybe low or in need of of an oil and filter change.

It should be a red, almost cherryade colour.

Share this post


Link to post
Share on other sites

You might want to have a look at the throttle body (working on the assumption that automatics have one! - never owned an auto). When it gets full of dirt and filth it can cause juddering and erratic revs, so a good clean will probably help.

Share this post


Link to post
Share on other sites

Let us know how you went on please

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now