Jump to content


Show
Photo

Heaters Only Blowing Cold Air


  • Please log in to reply
3 replies to this topic

#1 john500

john500

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: john
  • Ford Model: streetka
  • Year: 2005
  • Location: Renfrewshire

Posted 29 March 2013 - 11:02 AM

hi, my 05 streetka has now starting blowing cold air from heaters, had her running for 20 minutes and put on hot but nothing, plenty of water and head gasket seems fine,,water does look a little dirty though,,any ideas or assistance would be great :)



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 wase16ll

wase16ll

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,133 posts
  • Name: Tony
  • Ford Model: granada
  • Year: 1992
  • Location: Greater London

Posted 29 March 2013 - 11:47 AM

rarely worked on KA's, but seem to remember they suffered problems with the heater valve...sure somebody on here can give details with that.
failing that, thermostat and a good flush of the matrix.

#3 stef123

stef123

    Ford Enthusiast

  • Management
  • 4,655 posts
  • Name: Stef
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 29 March 2013 - 01:39 PM

Agree with Tony, the Heater control valve is usually a suspect on the Ka. They tend to stick either open or shut.



#4 john500

john500

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: john
  • Ford Model: streetka
  • Year: 2005
  • Location: Renfrewshire

Posted 29 March 2013 - 05:59 PM

thanks, can source these quite cheaply,,any ideas on fitting,,access etc..or is it one for mechanic, will give it a good flush also..




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users