Jump to content


Photo

Possible Steering Pump Problem


  • Please log in to reply
1 reply to this topic

#1 Advent

Advent

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: Keith
  • Ford Model: Mondeo Zetec TCDI
  • Year: 2010
  • Location: Tyne and Wear

Posted 29 March 2013 - 12:34 PM

Mondeo 59 reg. Registred Feb 2010, just had its 4th Service last month (Feb 2013).

Present mileage 50,600miles . In the last two weeks weeks I have noticed a light squeal

after a mile or so coming from the engine bay. This squeal developes after driving the first mile

of a journey and continues to the journeys end. Water Pump Steering pump not too sure however on

full lock of the steering wheel this squeal is more noticable.

Am I the unlucky one whos warranty has ran out last month ?

Could this be a common problem repairable at home i.e. belt change.

The last service was done by a Ford Dealer.

Help needed.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 bladeage

bladeage

    Settling In Well

  • New Member
  • PipPipPip
  • 82 posts
  • Name: PAUL
  • Ford Model: mondeo 2007 2.0 tdci old shape
  • Year: 2007
  • Location: Yorkshire

Posted 29 March 2013 - 07:27 PM

I think my mk3 had this same problem before I brought it and it was the steering rack that was changed.




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users