Jump to content


Photo

Mondeo Tddi 51 Plate


  • Please log in to reply
2 replies to this topic

#1 tonka12

tonka12

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: keith
  • Ford Model: mondeo tddi mk3
  • Year: 2002
  • Location: Essex

Posted 06 April 2013 - 10:35 AM

hi all new to the ford forum having problems with my tddi it runs for 10mins then cuts out and wont restart until its cooled down put f super on showing no faults if i start car and leave standing it wont happrn any help would be appreciated



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 06 April 2013 - 03:37 PM

a couple of common things to check, the crank sensor could be breaking down when hot or it could be covered in filings fron the dmf, also there is a relay for the fuel pump under the battery which can sometimes play up when hot so check for any signs of corrosion or damage.



#3 tonka12

tonka12

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: keith
  • Ford Model: mondeo tddi mk3
  • Year: 2002
  • Location: Essex

Posted 06 April 2013 - 05:56 PM

thx ill try those 2moro




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users