Jump to content


Photo

my stuffed escort


  • Please log in to reply
8 replies to this topic

#1 ant1985

ant1985

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: escort

Posted 21 March 2009 - 06:25 PM

my escort keeps hesitating :( . i've changed coil pack n still doing it any1 got any ideas please

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 21 March 2009 - 07:28 PM

What Escort is it?
Year, Model, Engine etc etc

#3 ant1985

ant1985

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: escort

Posted 21 March 2009 - 09:25 PM

1996 1.6 zetec mk 6

#4 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 21 March 2009 - 10:31 PM

Sounds like the idle control valve.

Take it off and give it a clean

#5 ant1985

ant1985

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: escort

Posted 22 March 2009 - 03:53 PM

i'll give a go thanx alot

#6 mr.c

mr.c

    Member

  • New Member
  • PipPip
  • 14 posts
  • Ford Model: Escort MK5
  • Location:

Posted 24 March 2009 - 07:22 PM

It could be the idle control valve if it has a flat spot on really low revs. it could also be the plugs/ leads/ injectors or just needs a good service.

Let us know how you get on.

#7 ant1985

ant1985

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: escort

Posted 24 March 2009 - 08:31 PM

i'll let you no thanx

#8 ant1985

ant1985

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: escort

Posted 30 March 2009 - 08:22 PM

It could be the idle control valve if it has a flat spot on really low revs. it could also be the plugs/ leads/ injectors or just needs a good service.

Let us know how you get on.

i have tried idle control valve and changed plugs and leads but it still hesatating any idea how to check the injectors please

#9 danny2252

danny2252

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: mondeo/ fiesta
  • Location:

Posted 01 April 2009 - 09:41 PM

i have tried idle control valve and changed plugs and leads but it still hesatating any idea how to check the injectors please


heey my mate has a focus 1.6 same engine as yours and his did this and then it got very bad and it was the cat blocked up so he took the cat off and poked it all out and runs like a dream now


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users