Jump to content


Photo

The 53 Plate Mondeo Tdci Saga Continues, Injector Coding


  • Please log in to reply
21 replies to this topic

#1 Rossitron

Rossitron

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: Ross
  • Ford Model: Mondeo
  • Year: 2003
  • Location: Caerphilly

Posted 12 April 2013 - 01:47 PM

I've been having problems for the last 2 months in starting on a morning, it will bump off and start with easy start straight away and then run fine for the rest of the day, until it is left overnight!

 

It also has the glow plug light problem when over gearing, revving too hard / quickly or progressing in 6th.

 

I did a leak off test, which showed that 3 injectors were leaking heavily, so I changed all the injectors and re-programmed them with F super. I am wondering whether I programmed them correctly as the injector number - cylinder number - firing order confuses me.

 

When looking at the injectors from the front, I programmed them in order from left to right, this is what the instructions for F super seemed to suggest, even though the order is shown as 1,3,4,2. The car seems to be running better, but it still wouldn't start right off the bat and the glow plug light is still happening.

 

There is some smoke when accelerating occasionally, but no white smoke. I have also changed the fuel filter and air filter. The codes I read before I encoded the injectors were:

 

 

P1000

P1211

P2291

 

and previously - P0251

 

I have looked all these up and it seems that maybe there is a loss in pressure, but there seems to be quite a few reasons why that could be happening.

 

any help would be appreciated.



 

 

 



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 12 April 2013 - 05:18 PM

mate by the time ya mess about with changing injectors etc,ya'd be as well taking your motor to a diesel specialist mechanic

personally I wouldnt even start messin about wi injectors,its asking for more bother. when folk start thinking "ah Ive got that cable,I'll do it myself & save a £100",it normally doesnt end well. where'd you get your injectors? please dont say scrappy/ebay lol



#3 wase16ll

wase16ll

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,133 posts
  • Name: Tony
  • Ford Model: granada
  • Year: 1992
  • Location: Greater London

Posted 12 April 2013 - 10:39 PM

although im not familiar with the f super...injectors need to be coded in firing order
so lets say you have 4 boxes in numerical order to type in the codes
first box, you type in code for no1 injector
second box, no 3 injector
third box, no 4 injector
fourth box no 2 injector

once coded, it needs to be driven at various speeds, often find it drives rough for a short while, but improves more you drive it....some ive done in the past can take 20mins at various speeds before it drives well.
hope that helps

#4 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,798 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 13 April 2013 - 06:30 AM

Poor cold starting is often because of the glow plugs 

 

Ive had my Mondeo mk3 8 years now - it runs perfectly (in fact much better than stock) its only ever been near a garage a handful of times, and apart from that i've done all my own work/ modifications on it,

 

There is no reason why you can't work on the car yourself - the chaps on the forum will help you

 

Injectors are not always the start, middle and end of the story (though it sometimes seems to me some people on forums think it is) the lift pump / main pump can break up and drop "swarf" into the system, a pattern diesel filter can give trouble (restricting flow)  these can throw up codes

 

The cold start problem may/ may not be connected with the injectors (may be a seperate issue, eg, glow pugs, as above)    

 

Have you fitted a solid EGR blanking plate yet? ("essential" for a Euro3 MK3 Mondeo)   



#5 Rossitron

Rossitron

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: Ross
  • Ford Model: Mondeo
  • Year: 2003
  • Location: Caerphilly

Posted 13 April 2013 - 11:16 AM

Thanks wase16ll, that's exactly the confirmation I was looking for! I rec0ded the injectors this morning and the rough idle improved instantly (although it wouldn't start on it's own straight away, but I didn't expect it to). I've been driving it around and had a few instances of the glow plug - limp mode and the engine management light stayed on for a while, but it has now gone. It feels better generally despite the glow plug issues, the rough idling especially.

 

FOCA - One of the first things I did was to change the filter, however it wasn't a Bosch one, as I read about this remedy and there was no mention of using Bosch, unfortunately I read this after installation! I have all the kit for leaning the EGR valve, but would you say blanking would be a better option?

 

Thanks for your help guys, been driving over ten years and learned more about cars from working on the Mondy in the last few months than I have ever learnt.



#6 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,798 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 13 April 2013 - 11:42 AM

Yes, blanking the EGR valve is a better option, once the EGR housing/ inlet manifold is cleaned it will stay clean this prevents any more carbon/ muck getting into the inlet manifold. engine often runs a little smoother with less flat spots,

 

A solid plate "fixes" a faulty (siezed/ leaking etc) egr valve and prevents trouble with it in the future, a Euro 3 Mondeo (yours) can be blocked with no problems/ a Euro 4 can sometimes generate a fault code and the engine light comes on (there should be no other problems)

 

Your EGR valve may be on the front-left or the back-right, a solid plate costs about £5 online, the best ones are thick (+3mm or more) stainless steel (does not rust or melt) if you can get them, mild steel can rust and aluminium can melt EGR = Exhaust Gas Recirculation, especially with rear EGRs (hotter/ closer to exhaust manifold)

 

You could clean your EGR valve, inlet manifold then blank it, it may be worth cleaning the intercooler while you are at it (both messy jobs) as the intercooler can act as a condenser for the oily "muck" that comes out of the engine breather

 

I aquired a secondhand inlet manifold to work on (it was an ST-TDCI one, it turned out to be exactly the same as the 2.0L one) i planned to gas- flow it so i wanted it clean - i spent days trying to clean it and in the end i gave it to a car valeter to clean (twice) who used de-greaser and a high power steam jetwash  before the inside was spotless - (so the carbon is hard to shift)

 

You could always just stick a solid blanking plate on it !

 

An operational EGR valve system is not nessesary for a diesel UK MOT and may even help as smoke is often reduced (only smoke/ particulates are tested on a diesel- for now)  



#7 Rossitron

Rossitron

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: Ross
  • Ford Model: Mondeo
  • Year: 2003
  • Location: Caerphilly

Posted 13 April 2013 - 11:52 AM

Would cleaning before blanking make much difference?

 

Also, do you think I should replace the filter witha  Bosch one?

 

Once the car has been started, it usually runs ok for the rest of the day, but sometimes it takes longer to fire when turning the key. Depressing the accelerator while cranking improves this, it feels like there is a lack of fuel getting through..

 

Gonna read the codes again later, see what's still lurking around.



#8 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,798 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 13 April 2013 - 12:11 PM

Would cleaning before blanking make much difference?

 

Also, do you think I should replace the filter witha  Bosch one?

 

Once the car has been started, it usually runs ok for the rest of the day, but sometimes it takes longer to fire when turning the key. Depressing the accelerator while cranking improves this, it feels like there is a lack of fuel getting through..

 

Gonna read the codes again later, see what's still lurking around.

The cold starting issues are more likely to be the glow plug/s because your car starts ok once it is warmed up -  when you use the throttle it increases the energy in the combustion chamber - raising the temp - so this may not be directly fuel related and may be heat related (glow plugs) otherwise you may have trouble starting when the engine is warm too 

 

I have heard that a pattern fuel filter can be more restrictive and reduce the diesel flow and a Bosch/ Ford one is better in this respect/ i would personally check the glow plugs and blank the EGR 1st, and swich the filter out if that did not work

 

The carbon from the EGR valve and the oil from the breather can mix in the inlet manifold practically "choking" the airflow (i've seen pictures on other forums) its worth checking it/ giving it a clean   



#9 Rossitron

Rossitron

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: Ross
  • Ford Model: Mondeo
  • Year: 2003
  • Location: Caerphilly

Posted 16 April 2013 - 08:17 AM

Update: Cleaned EGR valve yesterday, seems like it's stopped black smoking, but it hasn't had any effect on the starting / glow plug problem. Blanking plate has been ordered and i'm going to read up on cleaning the inlet manifold as I didn't have time to do that after work yesterday. 

 

Some other things I hadn't mentioned:

 

The problem started when it was snowing and the car was left un-started for quite a few days, could this have damaged something? At first I could jump it off from another car's battery but that stopped working (I had the battery tested and I was told it was fine). When I turn the engine off the car really judders to a holt and the car shakes quite badly, Finally, I noticed that the fuel access hole seems quite open, there is only a piece of metal hanging down, but quite a substantial gap around it, which doesn't seem right (pic attached).

Attached Thumbnails

  • image.jpeg


#10 wase16ll

wase16ll

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,133 posts
  • Name: Tony
  • Ford Model: granada
  • Year: 1992
  • Location: Greater London

Posted 16 April 2013 - 08:40 AM

have you changed the glow plugs?

#11 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,798 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 16 April 2013 - 10:49 AM

Update: Cleaned EGR valve yesterday, seems like it's stopped black smoking, but it hasn't had any effect on the starting / glow plug problem. Blanking plate has been ordered and i'm going to read up on cleaning the inlet manifold as I didn't have time to do that after work yesterday. 

 

Some other things I hadn't mentioned:

 

The problem started when it was snowing and the car was left un-started for quite a few days, could this have damaged something? At first I could jump it off from another car's battery but that stopped working (I had the battery tested and I was told it was fine). When I turn the engine off the car really judders to a holt and the car shakes quite badly, Finally, I noticed that the fuel access hole seems quite open, there is only a piece of metal hanging down, but quite a substantial gap around it, which doesn't seem right (pic attached).

Yes test/  change your glow plugs

 

When its cold outside a lead acid battery produces less power, diesels are harder to start at low temps, at very low temps the fuel waxes.  letting a lead-acid battery become flat can reduce its lifespan, best to keep it charged, apart from that leaving a car for a few days should not do any harm 

 

The juddering when you stop the engine could be the bottom engine/ gearbox mount, a common problem with older/ higher mileage mk3s the rubber seperates from the metal part of the mount

 

The flap in the filler is not important,  its just an anti - splash or anti - tamper flap,   mine is the same it does not matter (the cap goes over it anyway)



#12 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,466 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 16 April 2013 - 03:04 PM

jump starting the mondeo is not recomended as the smart charge system can put out up to 18volts when trying to recover the silver calcium battery,this can easily fry electrical componants, i am not saying this has happened but i would start by checking all the fuses and relays for the glow plugs and then check that the actual glow plugs are working when cold.



#13 Rossitron

Rossitron

    Member

  • New Member
  • PipPip
  • 12 posts
  • Name: Ross
  • Ford Model: Mondeo
  • Year: 2003
  • Location: Caerphilly

Posted 16 April 2013 - 04:50 PM

Thanks guys for your continued help.

 

I had a mechanic look at it when it started not starting.. he said the plugs were fine.How do I test them?

 

There are some fuses missing next to the battery, but they always have been. I think the other fuses are under the battery?

 

 

It's getting annoying now, since coding the injectors and cleaning the EGR, the car is running worse, I daren't even go into 4th as I keep getting the glowplug!!



#14 wase16ll

wase16ll

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,133 posts
  • Name: Tony
  • Ford Model: granada
  • Year: 1992
  • Location: Greater London

Posted 16 April 2013 - 06:16 PM

to test glow plugs
remove the electrical connectors
tast resistence between glow plug terminal and glow plug body...approx 0.2ohms

with electrics connected, cold engine, ign on, plugs should power up for approx 8 secs
cold engine, wait for glow light to extinguish, start engine and let idle, plugs should power up for approx 30 secs.

but to be honest, unless you know the history of plugs, may pay to change them anyway
originally you stated all was fine once started...so..

injector coding...if done in right sequence, did you get numbers from injectors themselves, or the sticker...if it was the sticker, you may find injectors have been changed/swapped about in past...would double check those codes on the injector themselves.
would blank that egr off and fit a quality filter and make sure all is bled properly..plus clear any stored codes


once that is all done, then if you still have problems, see what code/s are flagging up

#15 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,798 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 16 April 2013 - 08:44 PM

to test glow plugs
remove the electrical connectors
tast resistence between glow plug terminal and glow plug body...approx 0.2ohms

with electrics connected, cold engine, ign on, plugs should power up for approx 8 secs
cold engine, wait for glow light to extinguish, start engine and let idle, plugs should power up for approx 30 secs.

but to be honest, unless you know the history of plugs, may pay to change them anyway
originally you stated all was fine once started...so..

injector coding...if done in right sequence, did you get numbers from injectors themselves, or the sticker...if it was the sticker, you may find injectors have been changed/swapped about in past...would double check those codes on the injector themselves.
would blank that egr off and fit a quality filter and make sure all is bled properly..plus clear any stored codes


once that is all done, then if you still have problems, see what code/s are flagging up

Glow plugs should read approx 0.2 ohms >>if they are ok<<

 

If one or more is blown - it will read a much higher resistance on the multimeter (several mega- ohms or open - circut)

 

Many just replace the blown glow plugs to save money but i suppose if one or more are blown the others are prpbably on their way out  

 

Good answer and nice to have someone with actual technical knowlege & experience who is not just googling answers or re- gurgitating myths / propaganda    



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users