• Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


kpg

Lumpy, Bumpy Idle On 1.25 Zetec 2009

9 posts in this topic

Hi all, saw a few other threads on this but not really a definitive answer.

My Fez, when idle, is quite bumpy. I noticed it only slightly when I got the car around Oct/Nov last year but now 6 months on it's definitely worse. Not drastic but definitely worse. It's really annoying me now. The car drives fine, no loss of power or anything, not that I notice, but it's just the idle is very bumpy.

Anyone have any solutions on how to fix it?

Thanks.

Share this post


Link to post
Share on other sites
 

Anyone?

Share this post


Link to post
Share on other sites

Guess not. :mellow:

Share this post


Link to post
Share on other sites

I've got the 1.25 Zetec 2012 but I haven't had this problem, could be an early build issue?

Mine is quiet at idle and no noticeable shaking of the engine if that's what you mean by bumpy?

Share this post


Link to post
Share on other sites

I've got the 1.25 Zetec 2012 but I haven't had this problem, could be an early build issue?

Mine is quiet at idle and no noticeable shaking of the engine if that's what you mean by bumpy?

Whenever I'm sitting still in the car, in neutral, the car kinda 'shoves' every so often. Almost feels like it's about to stall then something 'shoves' the revs back up again but there's barely any noticeable movement in the rev needle. It's really annoying when sitting still in traffic or anywhere else.

Share this post


Link to post
Share on other sites

I know i had a problem where the engine would cut out and they upgrading the firmware on the ECU and worked quite smooth afterwards. Try taking it to Ford and seeing if it needs updating.

Share this post


Link to post
Share on other sites

Is there a possibility it could be the air con cutting in and out???

Regards Adrian

Share this post


Link to post
Share on other sites

If its not a sticky Idle Control Valve it could be a dirty injector. Have you tried putting a fuel injector cleaner through it

Share this post


Link to post
Share on other sites

I know i had a problem where the engine would cut out and they upgrading the firmware on the ECU and worked quite smooth afterwards. Try taking it to Ford and seeing if it needs updating.

The engine hasn't cut out on me yet but it always feels like it's about to.

Is there a possibility it could be the air con cutting in and out???

Regards Adrian

Nah it's definitely not the aircon. I never have it on. Too cold around these parts lol

If its not a sticky Idle Control Valve it could be a dirty injector. Have you tried putting a fuel injector cleaner through it

I haven't had the chance to try anything yet as it's away for repairs but how do you use a fuel injector cleaner?

Also could it be anything to do with the spark plugs or ignition leads?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now