Jump to content


Show
Photo

Probably Normal But ...


  • Please log in to reply
2 replies to this topic

#1 Irish Paddy

Irish Paddy

    Member

  • New Member
  • PipPip
  • 10 posts
  • Name: Patrick
  • Ford Model: Mondeo Mk3
  • Year: 2007
  • Location: Dublin

Posted 05 May 2013 - 08:10 AM

My Mondeo diesel (1997 Mk3, TDCI 130ps with 95k mls) is very lumpy and struggles a lot at first daily start up. It struggles for the first few minutes but then it's fine after a very short while of driving. Is it normal or might it need some maintenance do you think ?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 14,824 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 05 May 2013 - 12:31 PM

Check the glow plugs.

#3 Yorkie2

Yorkie2

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Name: Paul
  • Ford Model: Mondeo
  • Year: 2007
  • Location: Yorkshire

Posted 15 May 2013 - 05:51 AM


My Mondeo diesel (1997 Mk3, TDCI 130ps with 95k mls) is very lumpy and struggles a lot at first daily start up. It struggles for the first few minutes but then it's fine after a very short while of driving. Is it normal or might it need some maintenance do you think ?




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users