• Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save


duluxdoggy

Black Smoke Under Acceleration

8 posts in this topic

hi, i bought my mk3 mondeo 2.0 tdci 130 about 2 months ago, people keep telling me as i power away from em there is a LOT of black coming out of the exhaust. mainly at low revs it would seem, im told these have injector issues, regularly needing replacement costing a lot. this is not rly an option, i have been advised to get some redex, anyone any experience of this? and will the redex make much difference?

Share this post


Link to post
Share on other sites
 

could be tho,but maybe a split hose/pipe.have a look.

if you're going to add anything,try Forte injector cleaner. redex is crap

Share this post


Link to post
Share on other sites

Check your air hoses for splits especialy the one coming up from the intercooler to the egr, then clean your egr out. If those two dont fix it then blank your egr and see if that works.

Share this post


Link to post
Share on other sites

Got an 07 plate tdci had injectors and egr valve replaced and. Still smokes like hell under acceleration so not sure where to go from here!

Share this post


Link to post
Share on other sites

Got an 07 plate tdci had injectors and egr valve replaced and. Still smokes like hell under acceleration so not sure where to go from here!

Have you checked the air hoses for splits?

Share this post


Link to post
Share on other sites

may be the filter in the exhaust, this can get clogged up if you dont do alot of high rev driving. all you would need to do is run in along a motor way at high revs, id suggest 55mph in 4th maybe 3rd gear, as youd want to be in the slow lane because it blows all the crap out the filter. only a suggestion and worth a try, could be a cheap quick fix. worked on my 09 diesel

Share this post


Link to post
Share on other sites

Hi Benj3941.

Did you solve the black smoke problem on your 07 Tdci? I have same problem on mine and no idea whats causing it yet.

Any help be appreciated please.

Thanks. Matthew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now