Jump to content


Photo
- - - - -

Blower Issue! Blows Hot In Foot Well But Only Warm On Window And Full On Blower. Whyyy?

blower issue heat fiesta zetec

  • Please log in to reply
13 replies to this topic

#1 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 20 May 2013 - 02:37 PM

Hello!

 

I have an 07 Zetec S petrol 1.6.

 

Having issue with the blowers! When I use the blower that faces you, the ones that there are about 4 of the temperature is only just warm. You cannot notice it in the car unless you put your hand right next to it. However when I change the dial to the heater in the foot well but it is infact very warm (when on highest temp for both).

 

Why is this and how do I fix it?

 

I think there must be some internal flap or something that is not doing its job but I'm hoping someone here will have an idea + a solution!

 

 

Many thanks!



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 21 May 2013 - 10:46 AM

Anyone have any ideas?



#3 bigmunkynutz

bigmunkynutz

    Slightly Addicted now...

  • FOC Supporters
  • 347 posts
  • Name: Stephen
  • Ford Model: Fiesta Mk7.5 ZS 125PS+
  • Year: 2013
  • Location: Cheshire

Posted 21 May 2013 - 03:31 PM

I had a similar issue on my Volvo and it turned out the aircon needed re-gassing. Might be worth checking out...



#4 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 21 May 2013 - 04:23 PM

What speed are you running the blowers at?

 

to feel any sort of warmth it will need to be on 2 at least. If running at 4 you can hear the fan blowing etc does sound like the heater flap has become faulty.



#5 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 21 May 2013 - 07:57 PM

Would re gassing the air con really affect the blowers?

 

And I was using it on 3 mainly, the speed system like 1,2,3,4 works fine and the air can be felt- it's just the temp! 

 

I do believe the air con is empty so something to ponder perhaps!



#6 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 21 May 2013 - 08:10 PM

I dont think regassing will do heat as its a refridgerant that removes some moisture from the air.

I would say you have an issue with the coolant as i beleive heat is take from hot engine coolant....ie check your levels first

#7 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 21 May 2013 - 08:11 PM

Could have a block or leak in heater matrix

#8 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 21 May 2013 - 10:44 PM

I had a service done yesterday to see if that sorted the problem (new car) and they tested the antifreeze and it was fine.

 

If there was a block or leak in the heater matrix would that still distribute heat to one blower but not properly to another?

 

IF so how would I go about fixing it, and how much would this cost (if you can have an educated guess!)

 

Thank you :)



#9 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 21 May 2013 - 10:53 PM

Ah must have missed that bit with heat coming out...yeah sounds like the selector flap has become faulty...

#10 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 21 May 2013 - 10:59 PM

To check that would it just require taking apart the dash area to follow it back? OR is there another way?

 

Initially I thought it was not blowing hot at all, but then I felt some heat by my feet and discovered that seemed to be blowing very hot (maybe too hot?) maybe not! 



#11 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 22 May 2013 - 08:25 AM

Check to see if it is hot by your feet. If it is it sounds like the blower flaps are knackered and does require some work...i do have a guide on doing this on a peugeot but it may give an insight on what work is required...ill dig the link out

If its not hot by your feet i would suspect heater matrix

#12 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 22 May 2013 - 09:50 AM

Yeah would appreciate any guides you have!

 

So bigmunkynutz what was happening with your blowers?

 

I thought the air con and blowers were seperate systems so I am confused how they can affect one another!



#13 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 22 May 2013 - 01:44 PM

this may give some insight:

 

http://www.peugeotfo...p-repair-16582/



#14 trikidy

trikidy

    The Great Pretender

  • New Member
  • PipPipPipPip
  • 240 posts
  • Name: Reece
  • Ford Model: Fiesta Zetec S
  • Year: 2007
  • Location: Kent
Contributor

Posted 28 May 2013 - 01:44 PM

Just to end this thread, we took the head unit out and the fascia thing, looked at the back of the temperature knob and the wire had come lose!

We put it back in and added a small cable tie and everything is working great!

Will be moving onto air con next to see if that is okay!

 

Thanks for all the help!



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: blower, issue, heat, fiesta, zetec

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users