• Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


STRETCH2009.

Error Code

7 posts in this topic

hi all im nes to the ford um i have a code its a p 0101 could anyone help me plz if so what could b making this code thanks

Share this post


Link to post
Share on other sites
 

this should help

ult Code Definition
The Mass Airflow Sensor (MAF)
measures the amount of air entering the engine and the Engine Control
Module (ECM) uses the information to determine the proper amount of fuel
quantity and ignition timing. The P0101 trouble code is set when the
ECM detects a problem in the electrical circuit to the MAF Sensor.

  • Mass or Volume Flow Circuit/Performance Malfunction


Symptoms


  • Check Engine Light will illuminate
  • In some cases, there may be no adverse conditions noticed by the driver
  • In other cases, there may performance problems, such as a lack of
    power on acceleration, "coughing," misfiring, and/or backfiring
  • Problems idling
  • Black smoke from the tail pipe and poor fuel mileage
  • Other codes may be triggered by the Mass Air Flow Sensor problem
    such as Oxygen Sensor and/or Fuel Trim Lean/Rich codes (P0130/P0136,
    P0131/P0137, P0132/P0138, P0135/P0155, P0171/P0174, P0172/P0175)

Common Problems


  • Large vacuum leaks, split Intake Air Boot or PCV Hose, defective intake manifold gaskets
  • Mass Airflow Sensor (MAF)
  • Mass Air Flow Sensor circuit and or wiring problems
  • Defective Barometric Pressure Sensor
  • Dirty or contaminated Mass Air Flow Sensing wire or filament
  • PCM software needs to be updated

Share this post


Link to post
Share on other sites

thanks so what is the best thing for me to check first and the easy things lol

Share this post


Link to post
Share on other sites

its driving but just a lack of power and if i get it it start it up and try to rev the car it goes to stale but if i leave it a bit it will rev up fine

Share this post


Link to post
Share on other sites

try disconnecting the maf sensor and see if that makes any difference...if you are not sure where it is located, find the air filter box. Head upstream and you will see a plug with two wires coming out. Unplug this (this is your maf)

Share this post


Link to post
Share on other sites

i have done that it runs the same but i havnt got a machine to turn the code off to see if it comes back up with it unpluged

i took the sensor out and drove the car and it drove the same and i am all so missing some fuses f32 r7 f21 f14 15 16 im thinking maybe a new sensor at 150 pound

Share this post


Link to post
Share on other sites

with these faults dont waste money buying a sensor take it to a dealer and have it checked yes youll pay a dealer fee but youll only replace one part instead of replacing half a dozen trying to trace the fault as you see theres many things that can cause the fault

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now