Jump to content


Photo

Mondeo 2.0 Tdci Problem Help Me


  • Please log in to reply
No replies to this topic

#1 bigdaz

bigdaz

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Name: daryl
  • Ford Model: mondeo 2.0 tdci
  • Year: 2004
  • Location: London

Posted 26 May 2013 - 07:28 PM

hi every one im new on here i got myself a right turkey here i swapped a car for a 2004 mondeo 2.0 TDCI yesterday 25.5.13 .and it nackerd test drove fine on the way home i put my foot down going up a steep hill and the heater plug light started flashing and it cut out started back up agen and the light kept flashing but with a major power loss and a lot of smoke  got it home and left it 30 mins started bk up agen with no light on ran fine took it round the block a fyew times with black smoke  noticed it happend wen the revs went over 3k.. switched it of and restarted it was ok untill 3k but now its on all the time with no power .. iv cleaned and blanked the egr. replased cam sensor checked pipes and chenged fuel filter .and heater plugs no joy   wen im driving its smoking wight smoke all the time gets worse up the revs untill u cant c the car behind me but it sounds like a old diesel van verry nockey at 25k revs ... can aney body shed aney light on wat i may be  ....thanks daryl    theres no fault codes atall had a snap on reader on it



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users