• Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear


Manny444

I Just Replaced My Starter Motor And Now My Battery Isnt Charging ?

Recommended Posts

I had a problem with my starter motor clicking when engaging and disengaging, i had it replaced and that fixed the starting problem. Later that day my battery warning light began to flicker but when i accellerated it went away.

I checked the voltage on my battery whith the engine running and it was only showing 12.05 volts, the following day i checked it and it was showing 11.8 volts. So the alternator is not charging the battery what so ever. Could this be down to the starter motor being slightly more powerful then the original Ford Starter Motor.

Share this post


Link to post
Share on other sites
 

no mate, its a seperate circuit

check the battery connections and possibly the earth connection on the gearbox bell housing, they might have been disturbed when changing the starter

Share this post


Link to post
Share on other sites

A very good suggestion there Stef!

It sounds like if anything the alternator isnt connecting properly. Is there any chance you may have rubbed and slightly loosened any of the connectors to the alternator?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now