AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
andyr

No ABS check light (even though ABS is working!)

1 post in this topic

Hi,

Has anybody had any issues with the ABS on their Fiesta - I have a really wierd problem with the ABS check light on our 02 plate Fiesta. The ABS check light does not come on when you turn on the ignition and I would not really be that bothered but I have been told the car will fail it's MOT because of this. The strange bit is that the ABS seems to be working ok.

Things I have done so far :-

- Checked all ABS fuses and these are OK.

- Fault codes checked on engine ECU and ABS system - no ABS or ECU fault codes detected.

- Had the instrument cluster replaced with a new unit (also ran the test mode on the dash that turns on all the warning lights and the ABS light does come on!)

I am now starting to think that something strange must be going on with either the ABS unit or maybe the ECU even though they are not reporting any problems! I am starting to think that this is going to get expensive, the MOT is due next month so any tips or info much appreciated!!

Thanks

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0