Jump to content


Photo
- - - - -

No ABS check light (even though ABS is working!)


  • Please log in to reply
No replies to this topic

#1 andyr

andyr

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: 2002 Fiesta Ghia 1.6
  • Location:

Posted 27 March 2009 - 02:37 PM

Hi,
Has anybody had any issues with the ABS on their Fiesta - I have a really wierd problem with the ABS check light on our 02 plate Fiesta. The ABS check light does not come on when you turn on the ignition and I would not really be that bothered but I have been told the car will fail it's MOT because of this. The strange bit is that the ABS seems to be working ok.

Things I have done so far :-

- Checked all ABS fuses and these are OK.
- Fault codes checked on engine ECU and ABS system - no ABS or ECU fault codes detected.
- Had the instrument cluster replaced with a new unit (also ran the test mode on the dash that turns on all the warning lights and the ABS light does come on!)

I am now starting to think that something strange must be going on with either the ABS unit or maybe the ECU even though they are not reporting any problems! I am starting to think that this is going to get expensive, the MOT is due next month so any tips or info much appreciated!!
Thanks

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users