Jump to content


Show
Photo

Help Me


  • Please log in to reply
4 replies to this topic

#1 bigdaz

bigdaz

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Name: daryl
  • Ford Model: mondeo 2.0 tdci
  • Year: 2004
  • Location: London

Posted 06 June 2013 - 07:00 PM

hi every one been triying to find suttin on the net but cant find nothing thats why im posting this lol right iv got a 2004 mondeo 2.0 tdci witch i need sum guidance with. fitted a new injector today as number 2 was shot so swaped and recded it runs like a dream but wen i stop in trafic the glow plug light flashes and the dreaded limp mode switch of and bk on all ok if i keep the revs on 1000k ish let it tick over on its own the light flashes got a knock sensor bank 1 fault  .witch iv mounted off the block to eliminte a fault with a new one .  it only cums on on tick over then the coil light flashes  it runs verry lumpy but with no smoke and pulls well im a bit lost egr and inlet is spotles egr blanked off no splits in hoses .fitted a new cam sensor and fuel filter still the same .. i need a bit of help if aney one got aney sugestions please



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mondeotdci130

mondeotdci130

    Settling In Well

  • New Member
  • PipPipPip
  • 31 posts
  • Name: steve
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 07 June 2013 - 08:19 PM

any DTC's?



#3 bigdaz

bigdaz

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Name: daryl
  • Ford Model: mondeo 2.0 tdci
  • Year: 2004
  • Location: London

Posted 08 June 2013 - 07:46 AM

only wen it ticks over on its own then knock sencor bank 1 but it gows off if i restart it and keep driving and keep it above 1000rpm its fine all day if i do that but as soon as it ticks over on its own then i get my problem ..is there only one knock sensor ??



#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,464 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 08 June 2013 - 01:47 PM

sounds like a dodgy injector perhaps the one that was replaced,you could do a leak off test to confirm if the injectors are good,there is only one knock sensor as the ecu knows which injector is fireing and monitors accordingly.



#5 bigdaz

bigdaz

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Name: daryl
  • Ford Model: mondeo 2.0 tdci
  • Year: 2004
  • Location: London

Posted 08 June 2013 - 06:27 PM

ill have to do a nother leak of test is there aney way i can do a test or find out witch sylender has the diesel knock that would pin point a bad injector wouldent it ? could i do a home recon on my old injector it was prety bad filld leak of test in  1min 35 secons




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users