Jump to content


Photo

Pic/good Description Request - Mk2 2.0 Tdci Common Rail Plug


  • Please log in to reply
No replies to this topic

#1 gforce

gforce

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 787 posts
  • Name: Gary
  • Ford Model: Mondeo ST
  • Year: Non
  • Location: Tyrone

Posted 11 June 2013 - 04:08 PM

Guys, need a bit of help here...

 

I recently bought a tuning box online, seller claims it was removed from a Focus the same as mine. I tried plugging it in but got an 'Engine Sytems Fault' warning message on the LCD panel in the cluster.

 

I'm pretty sure from the trial fit that it's either not working or it isn't suitable for my car, but just want to check that it wasn't a blonde moment and that I was installing it correctly.

 

If anyone has a pic of the 2.0 TDCi engine bay and could identify the plug I need to fit it too it would be much appreciated for clarification.

 

Just want to make sure before I take action to seek a refund as he's adamant it worked on his car before removal. I've contacted the manufacturer, but as I feared they've been pretty vague in their responses...understandable really as I'm asking advice on an item I didn't buy directly through them.

 

Anyway, a pic or exact location description would be great if anyone could help.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users