• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience


markcab

Need Help Car Not Idleing And No Power When Warm

8 posts in this topic

hi all i have a escort 1.6 cab 1996 when car is cold the car runs fine but when it gets up to temp it jumps and dose not idle well it laboures plesase help and no power like the car has cut out but engine stil running and then picks up again

Share this post


Link to post
Share on other sites
 

When was it last serviced. Was the fuel filter changed. Could be a number of things including the coil pack, Leads, Plugs, partially clogged injectors.

Start with the normal service parts first if these haven't been changed for a while. Good luck

Share this post


Link to post
Share on other sites

Just saw your other post which says you've done the plugs, leads and fuel filter. It could be the coil pack. I would also check all the vacuum hoses for leaks. Try spraying some WD40 around the intake area and vacuum pipes while it is running. If the engine note changes you have an air leak.

Trouble is there are so many things it could be.

Share this post


Link to post
Share on other sites

When was it last serviced. Was the fuel filter changed. Could be a number of things including the coil pack, Leads, Plugs, partially clogged injectors.

Start with the normal service parts first if these haven't been changed for a while. Good luck

hi there have done ht leads fuel filter spark plugs and maf sensor

Share this post


Link to post
Share on other sites

hi there have done ht leads spark plugs fuel filter and maf sensor

Share this post


Link to post
Share on other sites

, from your description sounds like a flat spot on acceleration, would agree with check for air leak, would also give a rough idle that wouldnt be too noticable when cold, as it would be running a richer mixture at that point

most common place is the breather pipe/s collapse

Share this post


Link to post
Share on other sites

Moved to escort section

Share this post


Link to post
Share on other sites

hi all tonight i cleaned the coil pack out lets as they are very dirty inthe bottom car feels alot better but still missing would you agree it needs new coil pack as only doing it when car in warm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now