Jump to content


Show
Photo

The Famous Flashing Glow Plug Light...runs Fine After 10 Mins?!?!


  • Please log in to reply
No replies to this topic

#1 England blade

England blade

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Chris
  • Ford Model: Mondeo tdci mk.3
  • Year: 2005
  • Location: West Midlands

Posted 14 June 2013 - 06:36 PM

IVE RECENTLY BROUGHT A 55 PLATE 2 LITRE TDCI, IM PULLING MY HAIR OUT WITH THIS 1 AND WANDERED IF ANY1 ELSE HAS HAD THIS ISSUE? ...IVE HEARD ITS QUITE COMMON ON THE MK3 ENGINE TO HAVE THE GLOW PLUG LIGHT FLASHING AND GO INTO LIMB MODE...HOWEVER THE PROBLEM I AM HAVING IS WHEN I START THE CAR FROM COLD IT IS VERY SMOKEY (WHITE) AND REALLY QUITE CHUGGY... THIS LASTS FOR 10 TO 15 MINUTES AND THEN STOPS AND RUNS PERFECT WITH NO SMOKE...SO FAR I HAVE REMOVED AND CLEANED BOTH THE EGR VALVE AND THE INLET MANIFOLD TO NO AVAILE (ALTHOUGH THERE WAS ALOT OF CRUD IN BOTH)
SO THEN I GOT A FRIEND TO PLUG IT INTO DIAGNOSTICS...THIS GAVE THE CODES...P2288- INJECTOR CONTROL PRESSURE TOO HIGH... ANDP132B- TURBO CHARGER BOOST CONTROL.WE CHECKED THE FUEL PRESSURE THROUGH THE DIAGNOSTICS AND THIS WAS FINE, SLIGHTY HIGH IF ANYTHING BUT WE HAVE KIND OF RULED THAT OUT FOR NOW. MY FRIEND SEEMS TO THINK THAT IT MAY BE AN INJECTOR OR INJECTORS BUT THE THING I CANT UNDERSTAND IS, IF IT WAS AN INJECTOR WOULD IT STOP HAPPENING AFTER 15 MINS WHEN THE ENGINE IS WARM???
I THINK MY 1ST PORT OF CALL MAYBE TO REMOVE THE INJECTORS AND HAVE THEM CHECKED.I KNOW THAT THESE ENGINES ARE VERY EXPENSIVE TO FIX SO ANY ADVICE ANY BODY COULD GIVE TO POINT ME IN THE RIGHT DIRECTION WOULD BE GRATELY APPRECIATED... THANKS

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users