Jump to content


Show
Photo

Mk1 2Litre Weird Problem


  • Please log in to reply
2 replies to this topic

#1 david295

david295

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 282 posts
  • Name: David
  • Ford Model: Fiesta
  • Year: 2011
  • Location: Cheshire

Posted 18 June 2013 - 05:13 PM

I have a problem that i have had for a while but got worse today after cleaning throttle body.

 

If am driving along and coming to red lights, i dip clutch so am coasting, revs stay at 1500 and stay there until car rs at a complete stop, same if am changing gear revs stay high.

 

I cleaned throttle body out today, but it seems to of made it alot worse.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 STEADS

STEADS

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 821 posts
  • Name: NEIL
  • Ford Model: FOCUS 1.8 TDCI TITANIUM AND 2.0 TDCI
  • Year: 2009
  • Location: Cheshire

Posted 18 June 2013 - 05:23 PM

Throttle position sensor possibly ?

#3 david295

david295

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 282 posts
  • Name: David
  • Ford Model: Fiesta
  • Year: 2011
  • Location: Cheshire

Posted 18 June 2013 - 08:36 PM

I have just been on a long drive from Wirral to Manchester, and every time i came to off ramp on motorway put my foot on clutch and car just revs high, until I bring car to a complete stop, even if it's rolling a tiny bit it revs, and only goes to normal tick over when completely still.

 

Could it be when I took throttle butterfly valve out to completely clean it, I have cleaned it too much and took varnish of.




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users