• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Sign in to follow this  
Followers 0
andy2382

speedo problems

2 posts in this topic

hi all, dunno if this is the right section for this but i removed the speedo needle from my 2001 ford fiesta mk5 in order to paint it -ive put it back on and everything back together and now its reading zero constantly.

i did the same with the fuel gauge but that ones okay :(

ive checked to see if the needles sticking against the dial or anything like that, and it moves freely under gravity when i tilt the cluster around.

any ideas anyone?? :(:(

Share this post


Link to post
Share on other sites
 

hi all, dunno if this is the right section for this but i removed the speedo needle from my 2001 ford fiesta mk5 in order to paint it -ive put it back on and everything back together and now its reading zero constantly.

i did the same with the fuel gauge but that ones okay :(

ive checked to see if the needles sticking against the dial or anything like that, and it moves freely under gravity when i tilt the cluster around.

any ideas anyone?? :(:(

I know it sounds stupid but are you 100% sure you reconnected it properly? ( stranger things have happened and always try the obvious first )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0