• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Blue4life64

Help Display Staying On ?

10 posts in this topic

focus mk2.5 2008

we have just noticed the dash display is staying on ? ive disconnected the battery to see if that cleared it, I didn't and not its showing the wrong temp aswell ?

any body know how to correct ?

cheers

Share this post


Link to post
Share on other sites
 

The dash display does stay on for a while when you leave the car and lock it up. Its quite normal. Not sure if this is what you are referring too, but I am talking about the milage display ?

Share this post


Link to post
Share on other sites

yes the mileage display, I've never noticed it staying on before though ? would it drain the battery ?

Share this post


Link to post
Share on other sites

yes the mileage display, I've never noticed it staying on before though ? would it drain the battery ?

No it wont. Its fine. They all stay on for a good while before shutting off completely and the amount of power required to light that part of the display is tiny.

Share this post


Link to post
Share on other sites

it stays on whilst the ecu monitors the engine up to 40 mins max no longer than that

Share this post


Link to post
Share on other sites

Ok thanks for your help

Share this post


Link to post
Share on other sites

There have been reports from Ford that replacing the stereo with an aftermarket unit causes this, but only some people in Ford seem to know this. I have an aftermarket stereo in mine, and my light stays on 24/7 but I havent had a problem with it. If the car is going to be left unused for a while, either disconnect the battery, or connect a trickle charger (solar powered) just to keep it topped up.

Share this post


Link to post
Share on other sites

even with the aftermarket stereo if the wires are all the same in the connector the light should still go off most aftermarket stereos require the live and negative to be swapped an easy check is with the ignition off can the stereo be switched on if it can then the wiring is wrong as it should only work with switched ignition the ford one is designed to work for 1 hour but an aftermarket isnt so should switch with the ignition at position 2 only 9 out of ten times the black and red on the ford connector need swapped round to match the aftermarket. the problem with it staying on is the ecu never goes into sleep mode the alarm will not activate correctly either as theres a drain already present and the timer module will burn out causing issues further down the line

Share this post


Link to post
Share on other sites

In that case mine does in fact stay off with the ignition, so sounds correct, but still leaves the light on, I am not too worried though, my car is driven at least once a day, or at max is left one day unmoved!

Share this post


Link to post
Share on other sites

I to have the same prob and now my ford travelpilot fx navigation system has quit on me. I have check both the fuse in the back of the unit and the one in the board in the pax footwell. I have now pulled the 10A fuse so the display goes off. Any ideas guys ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now