• Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Blue4life64

Why Does My Temp Gauge Read -57C

Recommended Posts

ive noticed after disconnecting battery my temp gauge now reads -57c ?

anyone else had this ?

any ideas ?

cheers

Share this post


Link to post
Share on other sites
 

thats pretty random.

i had an issue with my Leon cupra r, i found that it would go to -257c when it froze over night.

i found that the sensor had come off when i was tinkering and the sensor was dangling in water when i use to clean it in one of the fog holders and didnt realise. not sure if thats the case or not. but hooked it back to the clip and it was fine.

Share this post


Link to post
Share on other sites

Sounds like its not reading the sensor properly, try resetting the car with the battery disconnect again, and wipe the wing-mirrors down, specifically on the underside...

Share this post


Link to post
Share on other sites

This happens to my car when the battery is disconnected. After a few hours (or over night) it returns to normal. I assume its just a case of it self recalibration.

Unless it stays that way for a few days I wouldn't be overly worried.

Stu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now