Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


bunny

Charging Problem

3 posts in this topic

2000 1.6 Escort Finesse. Turned the key yesterday, all dials went mad & it only just started, but ran ok. This morning would not start, even with booster & batt only showing 9volts on meter. Fitted new batt & started ok, but only showing 12.74 volts charging voltage at batt, but 14 volts at alternator terminal. With evrything on, charging voltage at batt is less than 12 volts. Is this duff alty or could something be draining between alty 7 batt?

Share this post


Link to post
Share on other sites
 

Sorted! Turned out to be weak cable connector at alternater. Replaced for 99p

Share this post


Link to post
Share on other sites

Good find.

Glad you got it sorted quickly.

Needles going nuts on start up is invariably a scuppered battery.

A stuffed alternator certainly didn't help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now