Jump to content


Show
Photo

2005 Focus St Help Please


  • Please log in to reply
1 reply to this topic

#1 HOTTIGGER

HOTTIGGER

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Name: matt
  • Ford Model: FOCUS ST-3
  • Year: 2005
  • Location: West Midlands

Posted 08 July 2013 - 09:24 PM

Hi all got a 2005 55reg focus st3, only owned it a day and the engines management light came on, two fault codes p0087 p2178, cleared the faults drove about 20 miles light came back on and I think the car went into limp mode as hardley any boost, I took the kam fuse out for half hour and the mil light went out drove another 20 miles the next day and the light back on with fault code p0087, I've searched Google and its saying change the fuel filter, there Is not a fuel filter fitted to the mk2 focus, does any1 have any ideas wot it could be ?, I'm thinking maby the fuel pressure sensor? Or maby fuel pump ?, any advice or suggesting would be great thanks in advanced.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,056 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 09 July 2013 - 02:44 AM

Fuel rail pressure too low and fuel too rich off idle the fuel filter is part of the pump sender unit check the fuel pump fuse and connections on the fuel pump also the fuel pump relay may bw sticking and need replaced it can be a faulty fuel module to be honwst a dealer would be best they can test the fuel pressure


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users