Jump to content


Show
Photo

Ford Focus Instrument Cluster/dashboard


  • Please log in to reply
4 replies to this topic

#1 smithy17

smithy17

    Settling In Well

  • New Member
  • PipPipPip
  • 30 posts
  • Name: Dan
  • Ford Model: Focus
  • Year: 2000
  • Location: Devon

Posted 09 July 2013 - 05:04 PM

Hi all

Just wandering what lights I should see stay on my dashboard/instrument cluster when the ignition is on the second setting (just before firing the engine) as I have the battery, oil, handbrake and a small orange pump looking light. They stay I until I start the engine?!?!

Thanks
Dan

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 09 July 2013 - 05:08 PM

You didnt say if it was petrol or diesel?



#3 smithy17

smithy17

    Settling In Well

  • New Member
  • PipPipPip
  • 30 posts
  • Name: Dan
  • Ford Model: Focus
  • Year: 2000
  • Location: Devon

Posted 09 July 2013 - 05:10 PM

Yeah my bad sorry was a rushed post ha. It's a 1.6 ford focus lx petrol 2000

Cheers
Dan

#4 johnH

johnH

    Ford Enthusiast

  • Moderator
  • 1,091 posts
  • Name: John
  • Ford Model: Focus mk2 Zetec 1.8 TDCI (Climate)
  • Year: 2006
  • Location: Tyne and Wear
Contributor

Posted 09 July 2013 - 05:15 PM

Ok you should expect the following:

 

- oil light

- Battery

- Handbrake

- engine management light

- ABS light (this may go off after self checks are done, around 3 secs)

- Fuel Light - if you have a low fuel level in tank

 

Once started all but handbrake will go off. (and fuel light - if you need fuel)

 

I ask about petrol or diesel as you will get glow plug lights on a diesel.



#5 smithy17

smithy17

    Settling In Well

  • New Member
  • PipPipPip
  • 30 posts
  • Name: Dan
  • Ford Model: Focus
  • Year: 2000
  • Location: Devon

Posted 09 July 2013 - 05:19 PM

Okay that's good , was abit worried as I thought they were just supposed to come on then disappear even before starting the engine.

Thanks for the quick response :)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users