• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear


Sign in to follow this  
Followers 0
blonde_abbie

help girl getting very angry

7 posts in this topic

my car is a 53 ka with 42000 i had to get head done a few months ago!! and it keeps cutting out wen im driving along i put my foot on accelirator and it just gives a lil burst of power then dies if i drop down the gear it will do the same i have to turn off my car and back on while im stil driving this is becoming quite dangerous now if any one could please help ill be most greatfull thanks

regards abbie

Share this post


Link to post
Share on other sites
 

my car is a 53 ka with 42000 i had to get head done a few months ago!! and it keeps cutting out wen im driving along i put my foot on accelirator and it just gives a lil burst of power then dies if i drop down the gear it will do the same i have to turn off my car and back on while im stil driving this is becoming quite dangerous now if any one could please help ill be most greatfull thanks

regards abbie

thats a bit rich having your head done with 42000 on the clock.

it could be a number of things ,

idle speed control valve

fuel filter blocked

oxegen sensor

throttle position sensor

try cleaning them and use a bit of wd40 , and check your pipes for leaks or splits and connected properly.

wife used to have a ford ka but i can't remember where these items are , they shoulding be to hard to find.

Share this post


Link to post
Share on other sites
thats a bit rich having your head done with 42000 on the clock.

it could be a number of things ,

idle speed control valve

fuel filter blocked

oxegen sensor

throttle position sensor

try cleaning them and use a bit of wd40 , and check your pipes for leaks or splits and connected properly.

wife used to have a ford ka but i can't remember where these items are , they shoulding be to hard to find.

Dont use WD40 to clean sensors, use carb cleaner. WD40 will leave a coating behind when it evaporates. Carb cleaner wont.

Share this post


Link to post
Share on other sites

i will have alook thanks i have had to new oxygen sensors on it because engine anagiment kept coming on sayin it needed done and its back on!! i havnt had it plugd in to see what it ses yet

Share this post


Link to post
Share on other sites

im no expert at all and dont have a clue but,your unlucky having to get a new head already with low milage did someone forget to top up the oil for a few months ? ,i think a match and big push on the car out the street should do the job sounds like your spending more than its worth,insurance comes in handy in these times of need not that im suggesting you take these measures lol

Share this post


Link to post
Share on other sites

Take it back to the garage that fitted the cylinder head and say it hasn't run right since they fitted it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0