Jump to content


Photo

2.0 Tdci Injectors


  • Please log in to reply
2 replies to this topic

#1 STEADS

STEADS

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 672 posts
  • Name: NEIL
  • Ford Model: FOCUS 1.8 TDCI TITANIUM AND 2.0 TDCI
  • Year: 2009
  • Location: Cheshire

Posted 20 July 2013 - 07:50 PM

Wonder if any one on here can shed any light on this just replaced the engine in my 2.0 tdci injectors came with engine now I know I will eventually have to have them coded to the ecu to run smoothly but would them not being programmed to the ecu for initial start up stop them opening .had it started briefly then ran out of juice more or less straight away aware of the probs with restarting but have juice at pump with no apparent air in line good fuel pressure but no start .so just wondering if the injectors are not opening due to not being programmed yet .any one had similar issues

Have something to contribute?

Sign in or register to start a topic...

#2 3putgrb

3putgrb

    Member

  • New Member
  • PipPip
  • 15 posts
  • Name: Gary
  • Ford Model: Mondeo 2.0 TDCI Ghia X
  • Year: 2004
  • Location: Hampshire

Posted 20 July 2013 - 09:13 PM

My understanding is tat the injectors will work but may not run very well if they fall outside of the pressure range of those calibrated to the ecu.

So I guess you have another problem that is causing it not to start.

#3 STEADS

STEADS

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 672 posts
  • Name: NEIL
  • Ford Model: FOCUS 1.8 TDCI TITANIUM AND 2.0 TDCI
  • Year: 2009
  • Location: Cheshire

Posted 20 July 2013 - 09:33 PM

Thanks for reply Gary will give it another go in the morning hopefully just air in the system once I can get it started I,l l pop it down to my mate to program the injectors.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users