Jump to content


Show
Photo
- - - - -

Horn Advise And Location Please ?


  • Please log in to reply
6 replies to this topic

#1 CharlieFarlie

CharlieFarlie

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 109 posts
  • Ford Model: Mondeo 2.0 TDCI,

Posted 22 July 2013 - 06:33 PM

Guys the horn on my Daughters 1.4 petrol Fiesta 2004 is not working.. The relay is clicking and the fuse is intact so I imagine its the horn unit itself that is gubbered......

 

Where exact is it located ? I have had only a cursory look but could not see it..

 

Thanks ! Charlie., 



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 CharlieFarlie

CharlieFarlie

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 109 posts
  • Ford Model: Mondeo 2.0 TDCI,

Posted 23 July 2013 - 05:39 PM

Thanks .....



#3 Fiesta1.25

Fiesta1.25

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 300 posts
  • Name: alan
  • Ford Model: Fiesta
  • Year: 2005
  • Location: WestLothian
Contributor

Posted 23 July 2013 - 06:33 PM

Remove the left hand headlight and the horn is located under it, its only held in with one securing nut onto a bracket.

#4 CharlieFarlie

CharlieFarlie

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 109 posts
  • Ford Model: Mondeo 2.0 TDCI,

Posted 24 July 2013 - 06:46 PM

Thanks Mate... Is that left hand from the front or rear ? Thanks again !



#5 Fiesta1.25

Fiesta1.25

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 300 posts
  • Name: alan
  • Ford Model: Fiesta
  • Year: 2005
  • Location: WestLothian
Contributor

Posted 24 July 2013 - 07:20 PM

Passenger side buddy...... I think :-)

#6 calmcdermott

calmcdermott

    Area Rep: Northeast

  • True Ford Enthusiast
  • PipPipPipPip
  • 579 posts
  • Name: Callum
  • Ford Model: Ford Fiesta ST500
  • Year: 2008
  • Location: Yorkshire

Posted 28 July 2013 - 12:00 AM

On my 2008 model it's underneath the front passenger headlight, only thing is my bracket was corroded and that's why mine wasn't working. Had to remove the wheel, the wheel arch lining and washer bottle to remove 1 bolt. Hopefully you can just undo the nut on the bracket and just replace the unit itself.

#7 sambooka

sambooka

    Sam Oglesby

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,031 posts
  • Name: sam
  • Ford Model: mk7 fiesta tdci zetec s
  • Year: 2011
  • Location: Lincolnshire

Posted 28 July 2013 - 10:33 AM

Yeh be sure it's not just a bad earth before buying another one

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users