Jump to content


Photo

Help Loss Of Power

loss of power starting problems struggling fuel spark plugs

  • Please log in to reply
No replies to this topic

#1 culturedan

culturedan

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Name: Dan
  • Ford Model: Fiesta 1.4 Mk6
  • Year: 2003
  • Location: Lancashire

Posted 23 July 2013 - 10:32 AM

Hello,

 

New to Ford owners club (unfortunately not an owner, but working on a friends car)

 

Shes a teacher and needs her car often, but she broke down at the side of m61 yesterday. RAC attended and advised that the struggling and misfire was due to very bad water damage around the spark plugs, I have since today had the top off, cleaned the area, and changed the spark plugs & HT leads for brand new. She is all sparkly now.

 

Now I was with her when we bought the car, the car was pokey, smooth running and no problems 'as such'.. only both before & after the plug change the car is very sluggish..

 

On start up it takes a good few pumps of the accelerator & turn over before starting, once warm, when stopped at traffic lights for sometime, the car wants a good few revs before picking up (without stalling).

 

When given a good boot, there is no poke like before, its like there is a great loss of power. I had an old Fiesta Mk5 zetec S once that had a similar problem, and turned out to be the fuel pump..

 

is there a possibility that this is also the case? and if so how much am I looking at for a part..

 

Ps. I am not a mechanic just (handy, savvy with cars, slightly) lol.

 

Anyway hope you can help..

 

Dan 



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: loss of power, starting problems, struggling, fuel, spark plugs

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users