• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Danz

Engine Malfunction Warning

2 posts in this topic

Hello. I have a 58 plate S-Max 2.0 TDCI Zetec with a FSH on 75k miles. Recently, the Engine Malfunction Display came on accompanied by the ESP warning light and the car immediately switched to the get you home 'limp mode'. After I got home I turned the engine off then on again and all the warnings had gone. A few days later it happened again so took it to our local garage (not Ford) and they plugged it into a diagnostics machine and no codes of concern were stored and they said nothing was wrong.

A week later it happened again so I took it to the Car Shop dealership I bought it from (with an extended warranty) and they once again put it through diagnostics. It threw up a code of P003A which equates to Turbo Charger Boost Control. Not being Ford specialists they have booked me into our local Ford dealership for further diagnostics.

Has anybody had experience of this kind of fault before. I'm confused to be honest and don't know if the ESP warning light is telling me there is problems with the ABS Sensors or module, or if it is a bi-product of the engine going into limp mode and the true fault lies within the Turbo Charger Boost Control.

Any views welcome.

Share this post


Link to post
Share on other sites
 

I have a very similar issue at the moment on my 55 CMAX, the ABS light keeps coming on randomly moreso above 25 degrees. I then get a few errors (one of which has on ocassion during the heat been low turbo boost pressure), but most the time the ABS light suggests I have an issue with the front right wheel, it shows different errors:

Input Circuit Failure

Input Circuit Error

Vehicle Speed Sensor Error

All of which seem to tie in with a duff sensor, but I havent been forced into limp home mode (even when it induced the EML to come on), but then if I turn the car off at less than 26, and back on again, the ABS light seems to go out, then comes back on when the temperature exceeds about 26 again, the light will come on again...

Check the error codes, see if you see anything along the lines of C1145. C1234. P0500 or others...

Hitchcock16 likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now