Jump to content


Photo

Where is the Lamba Senor Located?


  • Please log in to reply
2 replies to this topic

#1 SHANES9818

SHANES9818

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: Focus

Posted 03 April 2009 - 10:40 AM

Hi there

I own a V reg 2.0l Ford Focus.

I've got a few problems with it at the moment. One being a loss of power and hesitation when driving it. After an ECU Check it came back with one of the faults being a Lamba sensor which i guess is causing the above fault i mention.

Does any one know where this located in the engine?

Many thanks.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 4,505 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 03 April 2009 - 02:14 PM

Hi there

I own a V reg 2.0l Ford Focus.

I've got a few problems with it at the moment. One being a loss of power and hesitation when driving it. After an ECU Check it came back with one of the faults being a Lamba sensor which i guess is causing the above fault i mention.

Does any one know where this located in the engine?

Many thanks.

front exhaust down pipe i think
be someone along to comfrim this iam sure ;)

#3 SHANES9818

SHANES9818

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: Focus

Posted 03 April 2009 - 02:17 PM

front exhaust down pipe i think
be someone along to comfrim this iam sure ;)


Thanks mate.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users