Jump to content


Photo

K.a 09 Squeal !!


  • Please log in to reply
3 replies to this topic

#1 Oliverb

Oliverb

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 717 posts
  • Name: Ollie
  • Ford Model: Ford Focus Titanium
  • Year: 2008
  • Location: Cambridgeshire

Posted 06 August 2013 - 04:49 PM

Hii all .. 

my Partners 09 KA really Squeals when turned on .. 

Does anyone know what this could be .. 
it really doesn't sound to healthy...

Thanks in Advance 
 



Have something to contribute?

Sign in or register to start a topic...

#2 btmaldon

btmaldon

    Ford Enthusiast

  • FOC Supporters
  • 2,302 posts
  • Name: Bruce
  • Ford Model: Non Ford at the moment
  • Year: 2008
  • Location: Essex

Posted 06 August 2013 - 07:31 PM

Does it squeal when its first started, particularly when reved and stops/improves after a short while? If so its probably just the auxiliary belt slipping.



#3 Oliverb

Oliverb

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 717 posts
  • Name: Ollie
  • Ford Model: Ford Focus Titanium
  • Year: 2008
  • Location: Cambridgeshire

Posted 06 August 2013 - 08:43 PM

Does it squeal when its first started, particularly when reved and stops/improves after a short while? If so its probably just the auxiliary belt slipping.


Hi , it only makes this noise when turning on ignition :-/ 



#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,457 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 07 August 2013 - 02:48 PM

does it squeel for a short time and then stop if so it could be a noisy fuel pump.




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users