Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


bacahill

Leak In Footwell

3 posts in this topic

I've just made an account on this forum so hello guys, nice to meet you all ;)

So I thought you might be able to help me with a leak problem on my mk1 focus (51 plate). I've had a small leaking problem in the passenger side footwell since I bought the car about a year ago. It was never much so it didn't really bother me. Lately though, it's been raining pretty heavily and the puddle gets bigger each time. Luckily for me, I have thick ford mats that stop most of the water from soaking into the carpet. From the inside, you can see that the water has come from behind the dashboard in the center.

I've read that the pollen filter can quite often be the cause of the problem, but I was wondering if there's anything else that it could be. It might be worth mentioning that someone has done an awful job at putting the scuttle cover on - there's a bit gap (about 0.5-1cm) between the bottom of the windscreen and the scuttle itself. It also has 2 screws missing from it so I'm not sure if this is affecting what I assume is supposed to act as a gutter.

If anyone can help me out with what's causing it, I'd greatly appreciate it.

Share this post


Link to post
Share on other sites
 

it will be the pollen filter a revised scuttle panel should have been fitted and the filter seal will need replaced as well to prevent water leaks

post-8800-0-57941300-1376664761_thumb.jppost-8800-0-94842200-1376664762_thumb.jp

Share this post


Link to post
Share on other sites

Thanks for the reply, I'll get a replacement and if you don't here any more from me, it worked! :) cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now