Jump to content


Photo

Just Bought a Ford Focus Ghia 2005


  • Please log in to reply
6 replies to this topic

#1 Hicks

Hicks

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Ford Focus Ghia 2005 1.6
  • Location:

Posted 05 April 2009 - 04:24 PM

Hi guys,

I bought a second hand Focus last Friday and have noticed a few annoying things.

1. When i press the brake pedal the car makes a soft beeping noise. This can be heard from outside the car too. No notifications are shown on the dash board. Is this normal? If so what is its function!? Incidentally the brake pedal is very stiff compared to my old Clio...

2. The clock cannot be set in the built in radio (6000CD). I have read the manual and followed the instructions to manually change the time. This works but then reverts back to the original time (which is 1 hour 3 minutes behind). I assume the clock is set from the radio stations, so somehow I need to adjust my time zone or something? The radio does not have the RDS function mentioned in the manual.

Any help is appreciated :)

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 hodges9566

hodges9566

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: 2005 focus ghia 1.6 100bhp

Posted 08 December 2009 - 04:31 PM

Hi guys,

I bought a second hand Focus last Friday and have noticed a few annoying things.

1. When i press the brake pedal the car makes a soft beeping noise. This can be heard from outside the car too. No notifications are shown on the dash board. Is this normal? If so what is its function!? Incidentally the brake pedal is very stiff compared to my old Clio...

2. The clock cannot be set in the built in radio (6000CD). I have read the manual and followed the instructions to manually change the time. This works but then reverts back to the original time (which is 1 hour 3 minutes behind). I assume the clock is set from the radio stations, so somehow I need to adjust my time zone or something? The radio does not have the RDS function mentioned in the manual.

Any help is appreciated :)


Hi i have also resently purchased 2005 ghia 1.6 and also have the same problem, mine does it when lifting foot of the pedel and also when releasing the hand brake . this may indicate that the rear brake shoe which is also the hand brake shoe may need greasing where they rub against the brake back plate when actuated.Let us no if it is also on your handbrake. cheers.

#3 thesilverfox

thesilverfox

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 725 posts
  • Ford Model: Focus

Posted 08 December 2009 - 05:08 PM

Are either of your Ghia's automatic?

#4 hodges9566

hodges9566

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: 2005 focus ghia 1.6 100bhp

Posted 19 December 2009 - 04:31 PM

Are either of your Ghia's automatic?


mines a manual, why.

#5 thesilverfox

thesilverfox

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 725 posts
  • Ford Model: Focus

Posted 19 December 2009 - 06:18 PM

mines a manual, why.


I was wondering if the electronic parking brake was the issue.

#6 hodges9566

hodges9566

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: 2005 focus ghia 1.6 100bhp

Posted 05 February 2010 - 04:28 PM

Hi i have also resently purchased 2005 ghia 1.6 and also have the same problem, mine does it when lifting foot of the pedel and also when releasing the hand brake . this may indicate that the rear brake shoe which is also the hand brake shoe may need greasing where they rub against the brake back plate when actuated.Let us no if it is also on your handbrake. cheers.

just to up date on this issue i adjusted the hand brake to bite on two notches and the noise has dissapeared, any comments on this.

#7 Slugsy

Slugsy

    Settling In Well

  • New Member
  • PipPipPip
  • 57 posts
  • Ford Model: Focus ST170

Posted 05 February 2010 - 05:00 PM

yes your rear shoes quite probably need adjusting or the components greasing. As for the radio I have no idea. Sounds stupid but are you definately confirming the command of change of time after setting it?? Your not just exiting it are you?? As thats what it sounds like as it goes back to exactly 1hr 3 mins back

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users