Jump to content


Photo

Can Any One Help

mondeo tdci

  • Please log in to reply
4 replies to this topic

#1 stanly

stanly

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: josh
  • Ford Model: mondwo tdcu
  • Year: 2003
  • Location: Shropshire

Posted 22 August 2013 - 01:02 PM

Hi, hoping some one can help me i have a 2003 tdci mondeo which seems to be lacking power. I had a 52 plate before that drove really nice but this one seems very slow. Things i have done all ready, full service cleaned all the boost pipes no splits. There is no smoke at all not one bit cleaned egr valve. There is a thumping noise coming from air box and when i open it up it gets louder. Any help please also there are lights oh dash and had it put on diag machine and no fault codes either i am pulling my hair out

Have something to contribute?

Sign in or register to start a topic...

#2 stanly

stanly

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Name: josh
  • Ford Model: mondwo tdcu
  • Year: 2003
  • Location: Shropshire

Posted 22 August 2013 - 02:18 PM

Sorry there are no lights on dash like the em light or glow plug light

#3 benessex89

benessex89

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Name: ben
  • Ford Model: Mondeo mk3 Ghia 2.0 TDCI 130
  • Year: 2003
  • Location: Essex

Posted 23 August 2013 - 10:17 AM

I test drove a 55 plate that done exact same as you've said. I thought the cars must be that slow unti l drove the 1 I have now. Possibly not looked after or driven corectly? Cars made in the last 15 years or so, actually need to be driven quite hard from time to time, allot people drive diesels just about ticking over, which over say 100'000 is no good. Plus being run like that will make it slower than 1 that has been driven harder more often.

When i bought a fiesta st brand new, I asked ford on how to run it in, they said ''you dont, best thing to do is drive it like you stole it if you want it to perform like it should''.



#4 Daelpix

Daelpix

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 101 posts
  • Name: David
  • Ford Model: Fiesta Titanium 1.4 TDCI 3dr
  • Year: 2010
  • Location: Yorkshire

Posted 15 September 2013 - 08:02 PM

------



#5 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 638 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 16 September 2013 - 08:06 PM

You need some live data as well mate. No good guessing.

The thumping noise is NOT good though. Are you sure its coming from airbox? have you opened airbox up to see if theres a wee-man in there wi a hammer lol?no seriously though,I'd be worried if I had a thumping noise coming from my airbox.

Are you sure its not engine mount under airbox area? any chance we can hear a video clip of that noise?

you can get a knocking noise with duff injector/s.have you disconnected airbox & had a listen down the air pipe?




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users