Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Nixon

C Max Headlamp

3 posts in this topic

Hi,

Can someone help me on this one:

My offside head lamp lens on my c max 2005 failed the mot as it was oxidised. I got a replacement head lamp which I fixed myself. Reasonably straight forward or so I thought.

Now installed I don't have full beam and dipped head lights. They do come on slightly on side light setting only. The indicator works. I have a short circuit somewhere, I imagine.

I would really appreciate some help on this one.

Thanks

Share this post


Link to post
Share on other sites
 

did you plug the wires onto bulbs or check them, you have three bulbs, if yes take light back out and check bulbs also recheck main plug for wires are together properly.

Share this post


Link to post
Share on other sites

agree'd and also ensure that you have put the correct wires onto the correct bulbs (sounds silly but got to check these things)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now