Jump to content


Photo

Water Visible In Drivers Footwell Dribbling Down Rhs


Best Answer tomtommad, 27 October 2013 - 08:42 PM

Finally sorted the wet floor in drivers footwell. Before I got the car the windscreen had been replaced the fit was not perfect , along the drivers side seal of glass to car. Was letting in water. Solution was to dry out remove weather strip and use black mastic to resell windscreen. Now all ok. Hope this helps other Mondeo owners. Thanks for all advise. Steve Go to the full post


  • Please log in to reply
7 replies to this topic

#1 tomtommad

tomtommad

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Name: Steve
  • Ford Model: mondeo 1.8 zetec
  • Year: 2014
  • Location: Cheshire

Posted 06 September 2013 - 07:36 AM

i have looked at other posts re incorrect pollen filter fitting etc, i have replaced mine and it seals fine, i have a steady stream in water running in on the drivers footwell it is quite visible when it has rained and its running from behind kick panel then soaking the carpet front and back, the washer hoses have been checked rear wash also checked all washer hose connectors are fine , any suggestions on where this mystery dribble could be coming from

 

tearing hair out

 

muchly appreciate any advice

 

steve 2.0 TDCI Mondeo Ghia X 2007 MK3



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,727 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 06 September 2013 - 10:07 AM

Hi Steve,

 

Is there any water marks behind the scuttle panel under the bonnet? suggesting the water may have ran into the air intakes and down from there?



#3 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 15,825 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 06 September 2013 - 10:40 AM

Check if the filter or housing are wet.
The seal may look ok but might be pinched somewhere.

#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,727 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 06 September 2013 - 12:29 PM

also you didnt saw where in the drivers footwell you can see the water?



#5 tomtommad

tomtommad

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Name: Steve
  • Ford Model: mondeo 1.8 zetec
  • Year: 2014
  • Location: Cheshire

Posted 07 September 2013 - 08:19 AM

removed pollen filter housing and cleaned out leaves etc, then used mastik to re seat housing, cleaned the windscreen lip, 

(long piece of grooved plastic the windscreen sits on), cleaned everything.  waiting for some rain to see if it dribbles in, if it still does i will post a pic of where it dribbles inco footwell

many thanks people, fingers crossed

steve



#6 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 07 September 2013 - 08:04 PM

i dont think it'll be ur filter takin water in,but hope so for you though. thinking it might be coming in thru beside pedals maybe. had a mate had water trickling down inside o door pillar etc & ended up at his feet. 



#7 tomtommad

tomtommad

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Name: Steve
  • Ford Model: mondeo 1.8 zetec
  • Year: 2014
  • Location: Cheshire

Posted 27 October 2013 - 08:42 PM   Best Answer

Finally sorted the wet floor in drivers footwell. Before I got the car the windscreen had been replaced the fit was not perfect , along the drivers side seal of glass to car. Was letting in water. Solution was to dry out remove weather strip and use black mastic to resell windscreen. Now all ok. Hope this helps other Mondeo owners. Thanks for all advise. Steve

#8 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,727 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 28 October 2013 - 05:24 PM

Glad to see you got it resolved!



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users